summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Cooper2021-04-05 21:50:15 -0500
committerBrian Cooper2021-04-05 21:50:15 -0500
commit4dbf9e39b80fc99a01859db591fb51502fbe19b4 (patch)
tree3ffff3011bed42a3e444ebcf6fe3dcefbd7c9626
parentb4c1c6a6b7cf455dd10c006e250adee5a9e16231 (diff)
downloadaur-4dbf9e39b80fc99a01859db591fb51502fbe19b4.tar.gz
upgpkg: athens-git v1.0.0.beta.64.r3.g98a1fca-1
update athens-git: v1.0.0.beta.64.r3.g98a1fca
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 5 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f80b8ef58dc..491ad69733c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = athens-git
pkgdesc = Athens is an open-source and local-first alternative to Roam Research. Athens lets you take notes... Master branch
- pkgver = v1.0.0.beta.61.r3.g32ae526
+ pkgver = v1.0.0.beta.64.r3.g98a1fca
pkgrel = 1
url = https://github.com/athensresearch/athens
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index cda70039f2bb..370a5d99dda0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,8 @@
-# The following guidelines are specific to BZR, GIT, HG and SVN packages.
-# Other VCS sources are not natively supported by makepkg yet.
-
# Maintainer: Brian Cooper <brian at brian-cooper dot com>
# Contributor: Westofer Raymond <westoferraymond@gmail.com>
pkgname=athens-git
_pkgname=athens
-pkgver=v1.0.0.beta.61.r3.g32ae526
+pkgver=v1.0.0.beta.64.r3.g98a1fca
pkgrel=1
pkgdesc="Athens is an open-source and local-first alternative to Roam Research. Athens lets you take notes... Master branch "
arch=('i686' 'x86_64')
@@ -16,9 +13,6 @@ depends=("electron")
makedepends=("git" "nodejs" "leiningen" "yarn" "jq")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-#replaces=()
-#backup=()
-#options=()
install=
source=('athens::git+https://github.com/athensresearch/athens' 'athens.sh' 'athens.desktop')
noextract=()
@@ -26,9 +20,6 @@ md5sums=('SKIP'
'a11ab00f8e3f2be1320a5e67dcded1d1'
'dc18f4e2bdea985fff72911e868dfce9')
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
-
pkgver() {
cd "$srcdir/${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -36,7 +27,7 @@ pkgver() {
prepare() {
cd "$srcdir/${_pkgname}"
- # electron builder enforces email and homepage!
+ # electron builder enforces email and homepage
jq '.author|={"name":"athensresearch" , "email":"athensresearch@gmail.com"}' package.json > tmp.json && mv tmp.json package.json
jq '.homepage="https://github.com/athensresearch/athens"' package.json > tmp.json && mv tmp.json package.json
yarn upgrade electron@"$(</usr/lib/electron/version)"
@@ -55,20 +46,16 @@ build() {
-c.electronVersion="$(</usr/lib/electron/version)"
}
-#check() {
-#cd "$srcdir/${_pkgname}"
-#make -k check
-#}
package() {
- #desktop file
+ # desktop file
cd "$srcdir"
install -Dm644 -t "${pkgdir}/usr/share/applications" "${_pkgname}.desktop"
install -Dm755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
-
cd "$srcdir/${_pkgname}"
install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" LICENSE
install -Dm644 "build/icon.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/${_pkgname}.png"
install -Dm644 "dist/linux-unpacked/resources/app.asar" "${pkgdir}/usr/lib/${_pkgname}.asar"
}
+