summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwestofer2021-02-15 15:57:27 +0300
committerwestofer2021-02-15 15:57:27 +0300
commitab8b18b0636f170088c27a907442b4dabbf1c3ff (patch)
tree72d04c6afe22b65d0b51a5778c2850b98d99156d
parent2f9bb6d9e4d5194558283dc7a2bdfe67bed5cd74 (diff)
downloadaur-ab8b18b0636f170088c27a907442b4dabbf1c3ff.tar.gz
fix: fixed compiling issues, added i3868
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--athens-git2
-rw-r--r--athens.desktop (renamed from athens-git.desktop)2
-rw-r--r--athens.sh2
5 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7ff8d543564..71ca57856dbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,10 @@ pkgbase = athens-git
provides = athens
conflicts = athens
source = athens::git+https://github.com/athensresearch/athens
+ source = athens.sh
+ source = athens.desktop
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = athens-git
diff --git a/PKGBUILD b/PKGBUILD
index aa37699601ca..f402e5f75ac5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,9 @@ conflicts=("${pkgname%-git}")
#backup=()
#options=()
install=
-source=('athens::git+https://github.com/athensresearch/athens')
+source=('athens::git+https://github.com/athensresearch/athens' 'athens.sh' 'athens.desktop')
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP')
# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
# a description of each element in the source array.
@@ -60,13 +60,16 @@ build() {
package() {
#desktop file
- cd "$startdir"
- install -Dm644 -t "${pkgdir}/usr/share/applications" "${pkgname}.desktop"
- install -Dm755 -t "${pkgdir}/usr/bin" "$pkgname"
+ cd "$srcdir"
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${_pkgname}.desktop"
+ install -Dm755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+
cd "$srcdir/${_pkgname}"
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
- install -Dm644 "build/icon.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" LICENSE
+ install -Dm644 "build/icon.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/${_pkgname}.png"
+ install -Dm644 "dist/linux-unpacked/resources/app.asar" "${pkgdir}/usr/lib/${_pkgname}.asar"
+
}
diff --git a/athens-git b/athens-git
deleted file mode 100644
index 0a4dedfea3e1..000000000000
--- a/athens-git
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec electron /usr/lib/rocketchat-desktop.asar "$@"
diff --git a/athens-git.desktop b/athens.desktop
index 3f87340ec089..a9bcaa00fd2d 100644
--- a/athens-git.desktop
+++ b/athens.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Name=athens
- Exec=/opt/athens/athens %U
+ Exec=/usr/bin/athens
Terminal=false
Type=Application
Icon=athens
diff --git a/athens.sh b/athens.sh
new file mode 100644
index 000000000000..359395824b19
--- /dev/null
+++ b/athens.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec electron /usr/lib/athens.asar "$@"