summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-08-31 17:05:13 -0400
committerVincent Grande2020-08-31 17:05:13 -0400
commit6053134193626fe2af1a823587c57d27b6f027cc (patch)
tree9dc2b2fa35943dde752db9775d7a14d05496adec
parent136a73897692333a5a80aa73bb3bbf25f6d51323 (diff)
downloadaur-6053134193626fe2af1a823587c57d27b6f027cc.tar.gz
mirror official pkgbuild with meson
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD55
2 files changed, 36 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c81c0fbb8dfc..c93eb75fbeaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = atk-git
- pkgdesc = A library providing a set of interfaces for accessibility. Git version.
- pkgver = 2.16.0.8.g5dbc330.5dbc330
+ pkgdesc = Interface definitions of accessibility infrastructure
+ pkgver = 2.36.0
pkgrel = 1
- url = http://www.gnome.org
- arch = i686
+ url = https://gitlab.gnome.org/GNOME/atk
arch = x86_64
license = LGPL
makedepends = gobject-introspection
- makedepends = gnome-common-git
+ makedepends = git
+ makedepends = meson
depends = glib2
provides = atk
+ provides = libatk-1.0.so
conflicts = atk
- options = !libtool
- source = git://git.gnome.org/atk
- md5sums = SKIP
+ source = git+https://gitlab.gnome.org/GNOME/atk.git
+ sha256sums = SKIP
pkgname = atk-git
diff --git a/PKGBUILD b/PKGBUILD
index 92c6fa5a8f35..29a32f6169f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,40 @@
-# Maintainer: polterge|st
-# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=atk-git
-pkgver=2.16.0.8.g5dbc330.5dbc330
+pkgver=2.36.0
pkgrel=1
-pkgdesc="A library providing a set of interfaces for accessibility. Git version."
-arch=("i686" "x86_64")
-url="http://www.gnome.org"
-license=('LGPL')
-depends=('glib2')
-makedepends=('gobject-introspection' 'gnome-common-git')
-options=('!libtool')
-provides=('atk')
-conflicts=('atk')
-_gitname="atk"
-source=('git://git.gnome.org/atk')
-md5sums=('SKIP')
+pkgdesc="Interface definitions of accessibility infrastructure"
+url="https://gitlab.gnome.org/GNOME/atk"
+arch=(x86_64)
+license=(LGPL)
+depends=(glib2)
+makedepends=(gobject-introspection git meson)
+provides=(atk libatk-1.0.so)
+conflicts=(atk)
+source=("git+https://gitlab.gnome.org/GNOME/atk.git")
+sha256sums=('SKIP')
pkgver() {
- cd $_gitname
- echo $(git describe --always | sed 's/ATK_//g' | sed 's/_/./g' | sed 's/-/./g').$(git log --pretty=format:'%h' -n 1)
+ cd atk
+ git describe --tags | sed 's/^ATK_//;s/_/./g;s/-/+/g'
}
-build() {
- cd $_gitname
-
- sed -i -e '/AC_PATH_XTRA/d' configure.ac
- # autoreconf --force --install
+prepare() {
+ cd atk
+}
- ./autogen.sh --prefix=/usr --sysconfdir=/etc \
- --disable-schemas-compile
- make
+build() {
+ arch-meson atk build -D docs=false
+ ninja -C build
}
+#check() {
+# meson test -C build --print-errorlogs
+#}
+
package() {
- cd $_gitname
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" meson install -C build
}
+