summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2016-06-15 00:48:08 -0400
committeracerix2016-06-15 00:48:08 -0400
commite8ce63f07ac7f4745996fcb23197ae9da59d29c2 (patch)
tree0ca0c7d4f61703cb7689cb7e61d016197d3b9b84
downloadaur-e8ce63f07ac7f4745996fcb23197ae9da59d29c2.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7caaaa896c47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Wed Jun 15 04:47:24 UTC 2016
+pkgbase = atlas-cpp
+ pkgdesc = The C++ reference implementation of the WorldForge Atlas protocol.
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = http://www.worldforge.org/index.php/components/atlas-cpp/
+ arch = x86_64
+ license = GPL2
+ source = https://github.com/worldforge/atlas-cpp/archive/0.6.3.tar.gz
+ md5sums = 278e8c23e61720b165a62f64e74e9f8b
+
+pkgname = atlas-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd9240532d02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dylan Ferris <dylan@psilly.com>
+
+pkgname='atlas-cpp'
+pkgver=0.6.3
+pkgrel=1
+pkgdesc='The C++ reference implementation of the WorldForge Atlas protocol.'
+arch=('x86_64')
+url='http://www.worldforge.org/index.php/components/atlas-cpp/'
+license=('GPL2')
+source=("https://github.com/worldforge/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('278e8c23e61720b165a62f64e74e9f8b')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ libtoolize --force
+ aclocal
+ autoheader
+ automake --force-missing --add-missing
+ autoconf
+ ./configure
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make prefix="$pkgdir/usr/" install
+}
+
+# vim:set ts=2 sw=2 et: