summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-06-10 21:19:16 -0400
committeracxz2020-06-10 21:19:16 -0400
commit9a3848fac6a5ec6f9d54b6cae875a86c2c91dcaa (patch)
tree2ec8f202ce07673eecf179c88a9df7dbcbc32fde
parentb76652d134cfb0a4652317e95caa5da062828387 (diff)
downloadaur-9a3848fac6a5ec6f9d54b6cae875a86c2c91dcaa.tar.gz
updpkg atmi
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11d9b182f3ee..7ae94d165538 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = atmi
pkgdesc = Asynchronous Task and Memory Interface (ATMI) is a task graph framework for heterogeneous CPU-GPU systems.
- pkgver = 3.1.0
+ pkgver = 3.5.0
pkgrel = 1
url = https://github.com/RadeonOpenCompute/atmi
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = atmi
makedepends = cmake
depends = rocm-cmake
depends = rocm-device-libs
- source = atmi-3.1.0.tar.gz::https://github.com/RadeonOpenCompute/atmi/archive/rocm_3.1.0.tar.gz
- sha256sums = f2b072d79bb6987b638edabcf5aec7250079bf9aa60ca0c50b659744b8ed5f80
+ source = atmi-3.5.0.tar.gz::https://github.com/RadeonOpenCompute/atmi/archive/rocm-3.5.0.tar.gz
+ sha256sums = 3fb57d2e583fab82bd0582d0c2bccff059ca91122c18ac49a7770a8bb041a37b
pkgname = atmi
diff --git a/PKGBUILD b/PKGBUILD
index 5e089dab6056..947e837e7648 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=atmi
-pkgver=3.1.0
+pkgver=3.5.0
pkgrel=1
pkgdesc="Asynchronous Task and Memory Interface (ATMI) is a task graph framework for heterogeneous CPU-GPU systems."
arch=('x86_64')
@@ -8,16 +8,15 @@ url="https://github.com/RadeonOpenCompute/atmi"
license=('MIT')
depends=('rocm-cmake' 'rocm-device-libs')
makedepends=('cmake')
-source=("atmi-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/atmi/archive/rocm_$pkgver.tar.gz")
-sha256sums=('f2b072d79bb6987b638edabcf5aec7250079bf9aa60ca0c50b659744b8ed5f80')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/atmi/archive/rocm-$pkgver.tar.gz")
+sha256sums=('3fb57d2e583fab82bd0582d0c2bccff059ca91122c18ac49a7770a8bb041a37b')
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm/atmi \
- "$srcdir/atmi-rocm_$pkgver/src"
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/atmi \
+ "$srcdir/atmi-rocm-$pkgver/src"
make
}