summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-26 17:14:40 +0800
committerzxp198210052024-02-26 17:14:40 +0800
commit700a7c344d3dcdc80b57cab346d87b9f190cbdc3 (patch)
tree2edb11e642756a173235706225ffcf2427680a04
parent961f8fbbf8ca2346e09b5fb3414547b4c5305788 (diff)
downloadaur-700a7c344d3dcdc80b57cab346d87b9f190cbdc3.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--atmos-weather.sh9
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07a4b5a7ff4c..6b00b25325a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = atmos-weather-bin
pkgdesc = A lightweight weather app for receiving alerts and forecasts in the US.
pkgver = 2.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://atticuscornett.github.io/AtmosWeather/
arch = aarch64
arch = armv7h
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
depends = electron28
provides = atmos-weather=2.0.2
conflicts = atmos-weather
source = atmos-weather.sh
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
source_aarch64 = atmos-weather-2.0.2-aarch64.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.2/atmos-weather-linux-arm64.deb
sha256sums_aarch64 = daa9d166b30855842d0a54ec4bff41539061d08274a3b386623ce72520dc74fc
source_armv7h = atmos-weather-2.0.2-armv7h.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.2/atmos-weather-linux-armv7l.deb
diff --git a/PKGBUILD b/PKGBUILD
index 2fc8b0986f55..d33a3ef2e67f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=atmos-weather-bin
_pkgname="Atmos Weather"
pkgver=2.0.2
_electronversion=28
-pkgrel=1
+pkgrel=2
pkgdesc="A lightweight weather app for receiving alerts and forecasts in the US."
arch=(
'aarch64'
@@ -12,7 +12,7 @@ arch=(
)
url="https://atticuscornett.github.io/AtmosWeather/"
_ghurl="https://github.com/atticuscornett/AtmosWeather"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -22,16 +22,16 @@ source=("${pkgname%-bin}.sh")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-arm64.deb")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-armv7l.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-amd64.deb")
-sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+sha256sums=('0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
sha256sums_aarch64=('daa9d166b30855842d0a54ec4bff41539061d08274a3b386623ce72520dc74fc')
sha256sums_armv7h=('4a71beffd23fcecb8fc857e01af93029ef307ed975f1f5adabe8a1bb965d3431')
sha256sums_x86_64=('626483694f7c3d9af3408f93424e8c5c4b7dc1056a09c4a6c328a9eb8846d5b9')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
diff --git a/atmos-weather.sh b/atmos-weather.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/atmos-weather.sh
+++ b/atmos-weather.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file