summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-15 15:21:44 +0800
committerzxp198210052024-03-15 15:21:44 +0800
commitc0945b0319f854be332ed51a5ef19ff483d7dcc4 (patch)
treeb67b8c9d035e72968c9e477225ee29b91b924ceb
parent700a7c344d3dcdc80b57cab346d87b9f190cbdc3 (diff)
downloadaur-c0945b0319f854be332ed51a5ef19ff483d7dcc4.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--atmos-weather.sh8
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b00b25325a5..092b4f849f2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = atmos-weather-bin
pkgdesc = A lightweight weather app for receiving alerts and forecasts in the US.
pkgver = 2.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://atticuscornett.github.io/AtmosWeather/
arch = aarch64
arch = armv7h
@@ -11,7 +11,7 @@ pkgbase = atmos-weather-bin
provides = atmos-weather=2.0.2
conflicts = atmos-weather
source = atmos-weather.sh
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = atmos-weather-2.0.2-aarch64.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.2/atmos-weather-linux-arm64.deb
sha256sums_aarch64 = daa9d166b30855842d0a54ec4bff41539061d08274a3b386623ce72520dc74fc
source_armv7h = atmos-weather-2.0.2-armv7h.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.2/atmos-weather-linux-armv7l.deb
diff --git a/PKGBUILD b/PKGBUILD
index d33a3ef2e67f..3234408babd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=atmos-weather-bin
_pkgname="Atmos Weather"
pkgver=2.0.2
_electronversion=28
-pkgrel=2
+pkgrel=3
pkgdesc="A lightweight weather app for receiving alerts and forecasts in the US."
arch=(
'aarch64'
@@ -22,7 +22,7 @@ source=("${pkgname%-bin}.sh")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-arm64.deb")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-armv7l.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-amd64.deb")
-sha256sums=('0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('daa9d166b30855842d0a54ec4bff41539061d08274a3b386623ce72520dc74fc')
sha256sums_armv7h=('4a71beffd23fcecb8fc857e01af93029ef307ed975f1f5adabe8a1bb965d3431')
sha256sums_x86_64=('626483694f7c3d9af3408f93424e8c5c4b7dc1056a09c4a6c328a9eb8846d5b9')
@@ -30,6 +30,7 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/atmos-weather.sh b/atmos-weather.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/atmos-weather.sh
+++ b/atmos-weather.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file