summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-16 12:53:24 +0800
committerzxp198210052024-01-16 12:53:24 +0800
commitcc75840b09bcd4a91e2d6602c99d8bccdaa89299 (patch)
tree4ac8f5cc5e3c3563c968833b6741e1eb476ffda3
downloadaur-cc75840b09bcd4a91e2d6602c99d8bccdaa89299.tar.gz
update to 2.0.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--atmos-weather.sh15
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5ab62183988
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = atmos-weather-bin
+ pkgdesc = A lightweight weather app for receiving alerts and forecasts in the US.
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://atticuscornett.github.io/AtmosWeather/
+ arch = aarch64
+ arch = armv7h
+ arch = x86_64
+ license = GPL3
+ depends = electron28
+ provides = atmos-weather=2.0.1
+ conflicts = atmos-weather
+ source = atmos-weather.sh
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ source_aarch64 = atmos-weather-2.0.1-aarch64.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.1/atmos-weather-linux-arm64.deb
+ sha256sums_aarch64 = 16979c09ecb9c407572b7289a458e3f34c38db2cb68b7cce02ab7c915aa12ddf
+ source_armv7h = atmos-weather-2.0.1-armv7h.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.1/atmos-weather-linux-armv7l.deb
+ sha256sums_armv7h = a1240669eb568a51e6540817c98c236d2aacdaa9002d8fa8e94487c6cc183294
+ source_x86_64 = atmos-weather-2.0.1-x86_64.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.1/atmos-weather-linux-amd64.deb
+ sha256sums_x86_64 = ca74c23086dc71fd66494b6ad7a5fb39f6ba7231f5a7a705cae5a40c5699a4c6
+
+pkgname = atmos-weather-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a4847e80944
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=atmos-weather-bin
+_pkgname="Atmos Weather"
+pkgver=2.0.1
+_electronversion=28
+pkgrel=1
+pkgdesc="A lightweight weather app for receiving alerts and forecasts in the US."
+arch=(
+ 'aarch64'
+ 'armv7h'
+ 'x86_64'
+)
+url="https://atticuscornett.github.io/AtmosWeather/"
+_ghurl="https://github.com/atticuscornett/AtmosWeather"
+license=('GPL3')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ "electron${_electronversion}"
+)
+source=("${pkgname%-bin}.sh")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-arm64.deb")
+source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-armv7l.deb")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-amd64.deb")
+sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+sha256sums_aarch64=('16979c09ecb9c407572b7289a458e3f34c38db2cb68b7cce02ab7c915aa12ddf')
+sha256sums_armv7h=('a1240669eb568a51e6540817c98c236d2aacdaa9002d8fa8e94487c6cc183294')
+sha256sums_x86_64=('ca74c23086dc71fd66494b6ad7a5fb39f6ba7231f5a7a705cae5a40c5699a4c6')
+build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" -t "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/atmos-weather.sh b/atmos-weather.sh
new file mode 100644
index 000000000000..aacd8f895847
--- /dev/null
+++ b/atmos-weather.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron@electronversion@ "${_ASAR}" "$@"
+else
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+fi
+exit \ No newline at end of file