summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Hummel2022-07-10 20:42:56 -0700
committerDavid Hummel2022-07-10 20:52:39 -0700
commit75431f26a9a74057b868cc6be2aa28c16475ea94 (patch)
tree8e572e4171dee0f07a4d4039a135e9aab7fd0f26
downloadaur-75431f26a9a74057b868cc6be2aa28c16475ea94.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD68
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1546ed028ed9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = atom-community-git
+ pkgdesc = A hackable text editor for the 21st century, built on Electron, and based on everything we love about our favorite editors.
+ pkgver = 1.63.0_dev_0732c5430
+ pkgrel = 1
+ arch = x86_64
+ makedepends = git
+ makedepends = node-gyp
+ makedepends = nodejs-lts-gallium
+ makedepends = npm
+ makedepends = python
+ depends = libsecret
+ depends = libx11
+ depends = libxkbfile
+ provides = apm
+ conflicts = atom
+ source = git+https://github.com/atom-community/atom.git
+ sha256sums = SKIP
+
+pkgname = atom-community-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f0f54592d7f9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+atom
+atom-community-git-*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..307bad459961
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+_gitname=atom
+_pkgname=${_gitname}-community
+
+pkgname=${_pkgname}-git
+pkgver=1.63.0_dev_0732c5430
+pkgrel=1
+pkgdesc="A hackable text editor for the 21st century, built on Electron, and based on everything we love about our favorite editors."
+arch=("x86_64")
+
+conflicts=("${_gitname}")
+
+depends=("libsecret" "libx11" "libxkbfile")
+
+makedepends=("git" "node-gyp" "nodejs-lts-gallium" "npm" "python")
+
+provides=("apm")
+
+source=("git+https://github.com/${_pkgname}/${_gitname}.git")
+
+sha256sums=("SKIP")
+
+prepare() {
+ pushd ${_gitname}
+ if [ -d node_modules ]; then
+ node script/clean.js
+ fi
+ node script/bootstrap.js
+ popd
+}
+
+pkgver() {
+ cd ${_gitname}
+ printf "%s_%s" "$(npm pkg get version | sed 's/-/_/' | sed 's/"//g')" "$(git log -1 --pretty=format:'%h')"
+}
+
+build() {
+ cd ${_gitname}
+ node script/build.js --no-bootstrap
+}
+
+package() {
+ cd ${_gitname}
+
+ install -dm0755 "${pkgdir}/opt/${_pkgname}"
+ cp -r out/${_gitname}-dev-*/* "${pkgdir}/opt/${_pkgname}"
+
+ install -dm0755 "${pkgdir}/usr/share/applications"
+ sed -e "s|<%= appName %>|Atom Community|" \
+ -e "s|<%= description %>|${pkgdesc}|" \
+ -e "s|<%= installDir %>|/usr|" \
+ -e "s|<%= appFileName %>|${_gitname}|" \
+ -e "s|<%= iconPath %>|${_pkgname}|" \
+ resources/linux/atom.desktop.in > "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ for size in 16 24 32 48 64 128 256 512 1024; do
+ install -Dm0644 "resources/app-icons/dev/png/${size}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/${_pkgname}.png"
+ done
+
+ install -dm0755 "${pkgdir}/usr/bin"
+ ln -s /opt/${_pkgname}/atom "${pkgdir}/usr/bin/atom"
+ ln -s /opt/${_pkgname}/resources/app/apm/bin/apm "${pkgdir}/usr/bin/apm"
+}
+
+check() {
+ cd ${_gitname}
+ node script/test.js
+}