summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Hummel2022-12-04 09:30:42 -0700
committerDavid Hummel2022-12-04 09:30:42 -0700
commit8456ff4fe97d283dc6599fedc550bbd7e4227def (patch)
tree6d90bf840a6b299a9d241989943b3f4cce799b42
parentbb349d19f410289e0fb3e8b798776ba9e0f2e17a (diff)
downloadaur-8456ff4fe97d283dc6599fedc550bbd7e4227def.tar.gz
Add .desktop file patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--atom.desktop.in.patch13
3 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cd73158b463..0005685a385d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,8 +15,10 @@ pkgbase = atom-community-git
conflicts = atom
conflicts = apm
source = git+https://github.com/atom-community/atom.git
+ source = atom.desktop.in.patch
source = test.js.patch
sha256sums = SKIP
- sha256sums = dbb1855822cf5f279fa51df092fd2b5947ce150dfecd3015657e55f2edc11f21
+ sha256sums = 36cd22b6610978686409114361ee32edbb16a021408feb71d44e4e1119e397b4
+ sha256sums = cf45abaa2754fdc8c7e7796cf9f3da3c9363126c62f57aed4e4c9075bc496e37
pkgname = atom-community-git
diff --git a/PKGBUILD b/PKGBUILD
index c1d60471c502..c125b6f246a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,12 +16,13 @@ depends=("libsecret" "libx11" "libxkbfile")
makedepends=("git" "node-gyp" "nodejs-lts-gallium" "npm" "python")
-source=("git+https://github.com/${_pkgname}/${_gitname}.git" "test.js.patch")
+source=("git+https://github.com/${_pkgname}/${_gitname}.git" "atom.desktop.in.patch" "test.js.patch")
-sha256sums=("SKIP" "dbb1855822cf5f279fa51df092fd2b5947ce150dfecd3015657e55f2edc11f21")
+sha256sums=("SKIP" "36cd22b6610978686409114361ee32edbb16a021408feb71d44e4e1119e397b4" "cf45abaa2754fdc8c7e7796cf9f3da3c9363126c62f57aed4e4c9075bc496e37")
prepare() {
pushd ${_gitname}
+ patch --forward --strip=1 --input="${srcdir}/atom.desktop.in.patch"
patch --forward --strip=1 --input="${srcdir}/test.js.patch"
if [ -d node_modules ]; then
node script/clean.js
diff --git a/atom.desktop.in.patch b/atom.desktop.in.patch
new file mode 100644
index 000000000000..39d736017706
--- /dev/null
+++ b/atom.desktop.in.patch
@@ -0,0 +1,13 @@
+diff --git a/resources/linux/atom.desktop.in b/resources/linux/atom.desktop.in
+index 0677341dc..fa8cc243d 100644
+--- a/resources/linux/atom.desktop.in
++++ b/resources/linux/atom.desktop.in
+@@ -2,7 +2,7 @@
+ Name=<%= appName %>
+ Comment=<%= description %>
+ GenericName=Text Editor
+-Exec=env ATOM_DISABLE_SHELLING_OUT_FOR_ENVIRONMENT=false <%= installDir %>/bin/<%= appFileName %> %F
++Exec=env ATOM_DISABLE_SHELLING_OUT_FOR_ENVIRONMENT=false <%= installDir %>/bin/<%= appFileName %> --in-process-gpu --no-sandbox %F
+ Icon=<%= iconPath %>
+ Type=Application
+ StartupNotify=true