summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Hummel2022-12-03 10:50:04 -0700
committerDavid Hummel2022-12-03 10:50:04 -0700
commitbb349d19f410289e0fb3e8b798776ba9e0f2e17a (patch)
treef39dede7b93f27e083ea67272980b23f9859e6cb
parentb43ebb9113f295685e3f98c003adca6642fe182c (diff)
downloadaur-bb349d19f410289e0fb3e8b798776ba9e0f2e17a.tar.gz
Add test patch.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--test.js.patch16
3 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50e9c21738ed..7cd73158b463 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,8 @@ pkgbase = atom-community-git
conflicts = atom
conflicts = apm
source = git+https://github.com/atom-community/atom.git
+ source = test.js.patch
sha256sums = SKIP
+ sha256sums = dbb1855822cf5f279fa51df092fd2b5947ce150dfecd3015657e55f2edc11f21
pkgname = atom-community-git
diff --git a/PKGBUILD b/PKGBUILD
index fe81a93a3e1d..c1d60471c502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,12 +16,13 @@ depends=("libsecret" "libx11" "libxkbfile")
makedepends=("git" "node-gyp" "nodejs-lts-gallium" "npm" "python")
-source=("git+https://github.com/${_pkgname}/${_gitname}.git")
+source=("git+https://github.com/${_pkgname}/${_gitname}.git" "test.js.patch")
-sha256sums=("SKIP")
+sha256sums=("SKIP" "dbb1855822cf5f279fa51df092fd2b5947ce150dfecd3015657e55f2edc11f21")
prepare() {
pushd ${_gitname}
+ patch --forward --strip=1 --input="${srcdir}/test.js.patch"
if [ -d node_modules ]; then
node script/clean.js
fi
diff --git a/test.js.patch b/test.js.patch
new file mode 100644
index 000000000000..a5c52be2fdfb
--- /dev/null
+++ b/test.js.patch
@@ -0,0 +1,16 @@
+diff --git a/script/test.js b/script/test.js
+index c4e7b6660..ea74432f4 100755
+--- a/script/test.js
++++ b/script/test.js
+@@ -244,9 +244,8 @@ function runCoreMainProcessTests(callback) {
+ testPath
+ ];
+
+- if (process.env.CI && process.platform === 'linux') {
+- testArguments.push('--no-sandbox');
+- }
++ testArguments.push('--no-sandbox');
++ testArguments.push('--in-process-gpu');
+
+ const testEnv = Object.assign({}, prepareEnv('core-main-process'), {
+ ATOM_GITHUB_INLINE_GIT_EXEC: 'true'