summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwebslave2016-04-30 21:15:51 -0400
committerwebslave2016-04-30 21:15:51 -0400
commitce34042a3226d236741ddda1c6bbbf6bf15ed0e7 (patch)
treef104b36e2dad4389394b934486d1907c037d7815
parent4a5c1123d2b2a4fa230ddc2671c132425b131a04 (diff)
downloadaur-ce34042a3226d236741ddda1c6bbbf6bf15ed0e7.tar.gz
Forked from fusion809
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD71
-rw-r--r--atom-beta.desktop12
-rw-r--r--package.patch77
4 files changed, 49 insertions, 123 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 231c98934996..3953b90fc0de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = atom-editor-beta
- pkgdesc = Chrome-based text editor from Github - Beta Channel (A hackable text editor for the 21st Century)
- pkgver = 1.8.0.beta3
+ pkgdesc = Chrome-based text editor from GitHub - Beta Channel
+ pkgver = 1.8.0.3
pkgrel = 1
url = https://github.com/atom/atom
install = atom.install
@@ -10,7 +10,6 @@ pkgbase = atom-editor-beta
makedepends = git
makedepends = npm
depends = alsa-lib
- depends = desktop-file-utils
depends = gconf
depends = gtk2
depends = libgnome-keyring
@@ -20,16 +19,9 @@ pkgbase = atom-editor-beta
depends = nss
depends = python2
optdepends = gvfs: file deletion support
- conflicts = atom-editor-bin
- conflicts = atom-editor-git
conflicts = atom-editor-beta-bin
- conflicts = atom-editor
source = https://github.com/atom/atom/archive/v1.8.0-beta3.tar.gz
- source = atom-beta.desktop
- source = package.patch
sha256sums = 58c79049787a0b844c434d1364bb25ed2ce8176eaf565efaf9312bc6e68bca99
- sha256sums = 10e158a590ff3a52481ea30f3742c170c7b49557fc7f7af875394de91048311f
- sha256sums = fbd8e29cdde10d430d809ffb2bdd52c5a0af3af96ad882c4754c553fefa7b2db
pkgname = atom-editor-beta
diff --git a/PKGBUILD b/PKGBUILD
index 968a58ca59fe..5d70800912a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,73 @@
-# Maintainer: Jeffrey Shaffner <risoftwi@gmail.com>
-# Contributer: Matheus de Alcantara <matheus.de.alcantara@gmail.com>
+# Contributor: Matheus de Alcantara <matheus.de.alcantara@gmail.com>
+# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
+# Maintainer: Jeffrey Shaffner <risoft@gmail.com>
pkgname=atom-editor-beta
-_pkgbeta=3
+_pkgrel=3
_pkgver=1.8.0
-pkgver="${_pkgver}.beta${_pkgbeta}"
+pkgver="${_pkgver}.${_pkgrel}"
pkgrel=1
-pkgdesc='Chrome-based text editor from Github - Beta Channel (A hackable text editor
-for the 21st Century)'
+pkgdesc='Chrome-based text editor from GitHub - Beta Channel'
arch=('x86_64' 'i686')
url='https://github.com/atom/atom'
license=('MIT')
-depends=('alsa-lib' 'desktop-file-utils' 'gconf' 'gtk2' 'libgnome-keyring' 'libnotify' 'libxtst' 'nodejs' 'nss' 'python2')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libgnome-keyring' 'libnotify' 'libxtst' 'nodejs' 'nss' 'python2')
optdepends=('gvfs: file deletion support')
makedepends=('git' 'npm')
-conflicts=('atom-editor-bin' 'atom-editor-git' 'atom-editor-beta-bin' 'atom-editor')
+conflicts=('atom-editor-beta-bin')
install=atom.install
-source=("https://github.com/atom/atom/archive/v${_pkgver}-beta${_pkgbeta}.tar.gz"
- "atom-beta.desktop"
- "package.patch")
-
-sha256sums=('58c79049787a0b844c434d1364bb25ed2ce8176eaf565efaf9312bc6e68bca99'
- '10e158a590ff3a52481ea30f3742c170c7b49557fc7f7af875394de91048311f'
- 'fbd8e29cdde10d430d809ffb2bdd52c5a0af3af96ad882c4754c553fefa7b2db')
+source=("https://github.com/atom/atom/archive/v${_pkgver}-beta${_pkgrel}.tar.gz")
+sha256sums=('58c79049787a0b844c434d1364bb25ed2ce8176eaf565efaf9312bc6e68bca99')
prepare() {
- cd "atom-${_pkgver}-beta${_pkgbeta}"
+ cd "$srcdir/atom-${_pkgver}-beta${_pkgrel}"
sed -i -e "/exception-reporting/d" \
- -e "/metrics/d" package.json
+ -e "/metrics/d" \
+ -e "s/0.36.8/0.36.12/g" package.json
+
+ chmod 755 -R package.json
- patch -Np0 -i "$srcdir/package.patch"
+ sed -e "s/<%= description %>/$pkgdesc/" \
+ -e "s|<%= appName %>|Atom Beta|"\
+ -e "s|<%= installDir %>/share/<%= appFileName %>/atom|/usr/bin/atom-beta|"\
+ -e "s|<%= iconPath %>|atom-beta.png|"\
+ -e "s|GNOME;||" \
+ -e "s|text/plain;|application/javascript;application/json;application/postscript;application/x-csh;application/x-desktop;application/x-httpd-eruby;application/x-httpd-php;application/x-httpd-php3;application/x-httpd-php4;application/x-httpd-php5;application/x-latex;application/x-msdos-program;application/x-ruby;application/x-sh;application/x-shellscript;application/x-sql;application/x-tcl;application/x-tex;application/xhtml+xml;application/xml;application/xml-dtd;application/xslt+xml;text/css;text/csv;text/html;text/plain;text/xml;text/xml-dtd;text/x-asm;text/x-bibtex;text/x-boo;text/x-c++;text/x-c++hdr;text/x-c++src;text/x-c;text/x-chdr;text/x-csh;text/x-csrc;text/x-dsrc;text/x-diff;text/x-eiffel;text/x-fortran;text/x-go;text/x-haskell;text/x-java;text/x-java-source;text/x-lua;text/x-makefile;text/x-markdown;text/x-objc;text/x-pascal;text/x-perl;text/x-php;text/x-python;text/x-ruby;text/x-scala;text/x-scheme;text/x-sh;text/x-tcl;text/x-tex;text/x-vala;text/yaml;|" \
+ resources/linux/atom.desktop.in > resources/linux/atom-beta.desktop
}
build() {
- cd "$srcdir/atom-${_pkgver}-beta${_pkgbeta}"
+ cd "$srcdir/atom-${_pkgver}-beta${_pkgrel}"
- export PYTHON=python2
- script/build --build-dir "$srcdir/atom-build"
+ export PYTHON=/usr/bin/python2
+ until ./script/build --build-dir "$srcdir/atom-build"; do :; done
}
package() {
- cd "$srcdir/atom-${_pkgver}-beta${_pkgbeta}"
+ cd "$srcdir/atom-${_pkgver}-beta${_pkgrel}"
+
script/grunt install --build-dir "$srcdir/atom-build" --install-dir "$pkgdir/usr"
- [[ -f "${pkgdir}/usr/share/applications/atom-beta.destkop" ]] && rm -rf "${pkgdir}/usr/share/applications/atom-beta.destkop"
+ if [[ -d "$pkgdir/usr/share/atom" ]]; then
+ mv "$pkgdir/usr/share/atom" "$pkgdir/usr/share/atom-beta"
+ fi
+
+ if [[ -f "$pkgdir/usr/bin/atom" ]]; then
+ mv "$pkgdir/usr/bin/atom" "$pkgdir/usr/bin/atom-beta"
+ fi
+
+ if [[ -f "$pkgdir/usr/bin/apm" ]]; then
+ rm "$pkgdir/usr/bin/apm"
+ fi
+
+ ln -sf "${pkgdir}/usr/share/atom-beta/resources/app/apm/node_modules/.bin/apm" "${pkgdir}/usr/bin/apm-beta"
+
+ if [[ -f "$pkgdir/usr/share/applications/atom.desktop" ]]; then
+ rm "$pkgdir/usr/share/applications/atom.desktop"
+ fi
+
+ install -Dm644 resources/linux/atom-beta.desktop "$pkgdir/usr/share/applications/atom-beta.desktop"
+ install -Dm644 resources/app-icons/beta/png/1024.png "$pkgdir/usr/share/pixmaps/atom-beta.png"
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
- install -Dm644 "${srcdir}/atom-beta.desktop" "${pkgdir}/usr/share/applications/atom-beta.desktop"
}
diff --git a/atom-beta.desktop b/atom-beta.desktop
deleted file mode 100644
index fde1a538febf..000000000000
--- a/atom-beta.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Name=Atom Beta
-Comment=A hackable text editor for the 21st Century.
-GenericName=Text Editor
-Exec=atom-beta
-Icon=atom-beta
-Type=Application
-StartupNotify=true
-Categories=GNOME;GTK;Utility;TextEditor;Development;
-MimeType=text/plain;
-StartupWMClass=Atom
-
diff --git a/package.patch b/package.patch
deleted file mode 100644
index 266f73df2416..000000000000
--- a/package.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git package.json package.json
---- package.json
-+++ package.json
-@@ -12,7 +12,7 @@
- "url": "https://github.com/atom/atom/issues"
- },
- "license": "MIT",
-- "electronVersion": "0.36.8",
-+ "electronVersion": "0.36.12",
- "dependencies": {
- "async": "0.2.6",
- "atom-keymap": "6.3.2",
-
-diff --git spec/atom-environment-spec.coffee spec/atom-environment-spec.coffee
---- spec/atom-environment-spec.coffee
-+++ spec/atom-environment-spec.coffee
-@@ -365,7 +365,7 @@ describe "AtomEnvironment", ->
- updateAvailableHandler = jasmine.createSpy("update-available-handler")
- subscription = atom.onUpdateAvailable updateAvailableHandler
-
-- autoUpdater = require('remote').require('auto-updater')
-+ autoUpdater = require('electron').remote.require('auto-updater')
- autoUpdater.emit 'update-downloaded', null, "notes", "version"
-
- waitsFor ->
-
-diff --git spec/module-cache-spec.coffee spec/module-cache-spec.coffee
---- spec/module-cache-spec.coffee
-+++ spec/module-cache-spec.coffee
-@@ -8,13 +8,13 @@ describe 'ModuleCache', ->
- beforeEach ->
- spyOn(Module, '_findPath').andCallThrough()
-
-- it 'resolves atom shell module paths without hitting the filesystem', ->
-+ it 'resolves Electron module paths without hitting the filesystem', ->
- builtins = ModuleCache.cache.builtins
- expect(Object.keys(builtins).length).toBeGreaterThan 0
-
- for builtinName, builtinPath of builtins
- expect(require.resolve(builtinName)).toBe builtinPath
-- expect(fs.isFileSync(require.resolve(builtinName)))
-+ expect(fs.isFileSync(require.resolve(builtinName))).toBeTruthy()
-
- expect(Module._findPath.callCount).toBe 0
-
-diff --git spec/window-event-handler-spec.coffee spec/window-event-handler-spec.coffee
---- spec/window-event-handler-spec.coffee
-+++ spec/window-event-handler-spec.coffee
-@@ -75,7 +75,7 @@ describe "WindowEventHandler", ->
-
- describe "when a link is clicked", ->
- it "opens the http/https links in an external application", ->
-- shell = require 'shell'
-+ {shell} = require 'electron'
- spyOn(shell, 'openExternal')
- link = document.createElement('a')
-
-diff --git src/module-cache.coffee src/module-cache.coffee
---- src/module-cache.coffee
-+++ src/module-cache.coffee
-@@ -202,13 +202,13 @@ registerBuiltins = (devMode) ->
-
- atomShellRoot = path.join(process.resourcesPath, 'atom.asar')
-
-- commonRoot = path.join(atomShellRoot, 'common', 'api', 'lib')
-- commonBuiltins = ['callbacks-registry', 'clipboard', 'crash-reporter', 'screen', 'shell']
-+ commonRoot = path.join(atomShellRoot, 'common', 'api')
-+ commonBuiltins = ['callbacks-registry', 'clipboard', 'crash-reporter', 'shell']
- for builtin in commonBuiltins
- cache.builtins[builtin] = path.join(commonRoot, "#{builtin}.js")
-
-- rendererRoot = path.join(atomShellRoot, 'renderer', 'api', 'lib')
-- rendererBuiltins = ['ipc-renderer', 'remote']
-+ rendererRoot = path.join(atomShellRoot, 'renderer', 'api')
-+ rendererBuiltins = ['ipc-renderer', 'remote', 'screen']
- for builtin in rendererBuiltins
- cache.builtins[builtin] = path.join(rendererRoot, "#{builtin}.js")