summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamantha McVey2016-12-23 13:13:31 -0800
committerSamantha McVey2016-12-23 13:13:31 -0800
commitb6784daf57bae39a4075fe48e3c7f9a2217b3dff (patch)
tree2402d6863496457a7ca0581dd877035c5b643e92
parenta2f41be780d9e3bcbb772db2c27ec1685f814e28 (diff)
downloadaur-b6784daf57bae39a4075fe48e3c7f9a2217b3dff.tar.gz
Update script to grab the latest dev version from Atom's feed
This should make sure that the package will check for the version on being built and build the most recently released dev version.
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a44478dd78b..595c9e11a05a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,17 @@
# Contributor: Andre Miranda <andreldm1989 AT gmail DOT com>
# Contributor: Tom Bu <tom.bu AT members.fsf.org>
# Contributor: John Reese <john@noswap.com>
+# Contributor: Samantha McVey <samantham@posteo.net>
# Upstream URL: https://github.com/atom/atom
pkgname=atom-editor-beta-bin
-_ver=1.12.0
-_beta=beta3
-pkgver="${_ver}.${_beta}"
+pkgver=1.13.0.beta8
+pkgver() {
+ curl -sS https://github.com/atom/atom/releases.atom | grep -Eo 'v.*?beta([0-9]+)' | head -n 1 | sed -e 's/-/./' -e 's/v//'
+}
+get_version() {
+ printf "%s" $(pkgver) | sed -e 's/\(.*\)\.beta/v\1-beta/'
+}
pkgrel=1
pkgdesc="Chrome-based text editor from Github - Beta Channel - Precompiled binary from official repository"
arch=('x86_64')
@@ -25,7 +30,7 @@ install=$pkgname.install
md5sums=('SKIP'
'501719c940fcd9c3d82fb8edebdaae09'
'b05aef80afa76162ff9a1992cef3f0f9')
-source=("atom-amd64-v${_ver}-${_beta}.deb::https://atom-installer.github.com/v${_ver}-${_beta}/atom-amd64.deb"
+source=("atom-amd64-$(get_version).deb::https://atom-installer.github.com/$(get_version)/atom-amd64.deb"
atom-python.patch
startupwmclass.patch)