summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Klassen2015-12-16 13:36:04 -0800
committerJordan Klassen2015-12-16 13:36:04 -0800
commit0a3073f25a1065156ed60f34b2eac17505ea6c53 (patch)
treeb25261bad0f4a163ce09b34e2a2c5271fa30f697
parent9669ed27ae530d7f285c00db2066fcea6f385e19 (diff)
downloadaur-0a3073f25a1065156ed60f34b2eac17505ea6c53.tar.gz
:arrow_up: 1.3.2
Also adds support for a flags file
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
-rw-r--r--atom-editor-bin.install5
-rw-r--r--atom-python.patch22
4 files changed, 36 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6c5561b999c..3fe09af0ee7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 10 20:37:44 UTC 2015
+# Wed Dec 16 21:10:42 UTC 2015
pkgbase = atom-editor-bin
pkgdesc = Chrome-based text editor from Github - Precompiled binary from official repository
- pkgver = 1.3.1
+ pkgver = 1.3.2
pkgrel = 1
url = https://github.com/atom/atom
install = atom-editor-bin.install
@@ -15,19 +15,19 @@ pkgbase = atom-editor-bin
depends = libxtst
depends = nss
depends = python2
- depends = gvfs
depends = xdg-utils
depends = desktop-file-utils
depends = alsa-lib
depends = libgnome-keyring
+ optdepends = gvfs
conflicts = atom-editor
conflicts = atom-editor-git
conflicts = atom-editor-git-tagged
options = !strip
- source = atom-amd64-v1.3.1.deb::https://github.com/atom/atom/releases/download/v1.3.1/atom-amd64.deb
+ source = atom-amd64-v1.3.2.deb::https://github.com/atom/atom/releases/download/v1.3.2/atom-amd64.deb
source = atom-python.patch
- md5sums = 54c0f62e18f0d74fbf8dc9b46a681bed
- md5sums = dbb685607dea46517de0a27e24085bf4
+ md5sums = a005eb2b6cedd119dc944d580027662d
+ md5sums = 9c752be551429c6ce5946d4fcae24464
pkgname = atom-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1047a0bf6477..18a02a4c455c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,20 @@
# Upstream URL: https://github.com/atom/atom
pkgname=atom-editor-bin
-pkgver=1.3.1
+pkgver=1.3.2
pkgrel=1
pkgdesc="Chrome-based text editor from Github - Precompiled binary from official repository"
arch=('x86_64')
url="https://github.com/atom/atom"
license=('MIT')
options=(!strip)
-depends=('git' 'gconf' 'gtk2' 'libnotify' 'libxtst' 'nss' 'python2' 'gvfs' 'xdg-utils' 'desktop-file-utils' 'alsa-lib' 'libgnome-keyring')
+depends=('git' 'gconf' 'gtk2' 'libnotify' 'libxtst' 'nss' 'python2' 'xdg-utils' 'desktop-file-utils' 'alsa-lib' 'libgnome-keyring')
+optdepends=('gvfs')
conflicts=('atom-editor' 'atom-editor-git' 'atom-editor-git-tagged')
install=$pkgname.install
-md5sums=('54c0f62e18f0d74fbf8dc9b46a681bed'
- 'dbb685607dea46517de0a27e24085bf4')
+md5sums=('a005eb2b6cedd119dc944d580027662d'
+ '9c752be551429c6ce5946d4fcae24464')
source=("atom-amd64-v${pkgver}.deb::https://github.com/atom/atom/releases/download/v${pkgver}/atom-amd64.deb"
atom-python.patch)
diff --git a/atom-editor-bin.install b/atom-editor-bin.install
index 959a05111b50..03028cb14761 100644
--- a/atom-editor-bin.install
+++ b/atom-editor-bin.install
@@ -3,6 +3,10 @@ msg_blue() {
printf "${blue}==>${bold} $1${all_off}\n"
}
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
_update() {
msg_blue "Updating desktop MIME database..."
update-desktop-database -q
@@ -14,6 +18,7 @@ post_install() {
post_upgrade() {
_update
+ note "Custom flags can now be put directly in: ~/.config/atom-editor-flags.conf"
}
post_remove() {
diff --git a/atom-python.patch b/atom-python.patch
index af5e42399a7c..e54a2fcf78b5 100644
--- a/atom-python.patch
+++ b/atom-python.patch
@@ -1,15 +1,33 @@
--- a/usr/bin/atom
+++ b/usr/bin/atom
-@@ -1,5 +1,8 @@
+@@ -1,5 +1,13 @@
#!/bin/bash
++# Allow users to override command-line options
++if [[ -f ~/.config/atom-editor-flags.conf ]]; then
++ ATOM_USER_FLAGS="$(cat ~/.config/atom-editor-flags.conf)"
++fi
++
+export PYTHON=python2
+unset GTK_IM_MODULE QT_IM_MODULE XMODIFIERS
+
if [ "$(uname)" == 'Darwin' ]; then
OS='Mac'
elif [ "$(expr substr $(uname -s) 1 5)" == 'Linux' ]; then
-
+@@ -99,11 +107,11 @@ elif [ $OS == 'Linux' ]; then
+ [ -x "$ATOM_PATH" ] || ATOM_PATH="$TMPDIR/atom-build/Atom/atom"
+
+ if [ $EXPECT_OUTPUT ]; then
+- "$ATOM_PATH" --executed-from="$(pwd)" --pid=$$ "$@"
++ "$ATOM_PATH" --executed-from="$(pwd)" --pid=$$ $ATOM_USER_FLAGS "$@"
+ exit $?
+ else
+ (
+- nohup "$ATOM_PATH" --executed-from="$(pwd)" --pid=$$ "$@" > "$ATOM_HOME/nohup.out" 2>&1
++ nohup "$ATOM_PATH" --executed-from="$(pwd)" --pid=$$ $ATOM_USER_FLAGS "$@" > "$ATOM_HOME/nohup.out" 2>&1
+ if [ $? -ne 0 ]; then
+ cat "$ATOM_HOME/nohup.out"
+ exit $?
--- a/usr/share/applications/atom.desktop
+++ b/usr/share/applications/atom.desktop