summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandya2015-09-23 17:19:51 +0200
committerandya2015-09-23 17:19:51 +0200
commit0b105d7b0e9a398eb8a8af06d984826581c389f6 (patch)
treebe39bdf5cd1fd0577df88efa8794000087a1359a
parent0e8854b14ef4f6e77fd24c45eaae03f9fd5e23b8 (diff)
downloadaur-0b105d7b0e9a398eb8a8af06d984826581c389f6.tar.gz
Better versioning
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7ccb29059f5..5508f357441f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,8 @@
# Upstream URL: https://github.com/atom/atom
# Please do mind that pkgbuild will automagically update
-# to latest tagged release, there's no need to manually change pkgver.
+# to latest tagged release (you could have problems if you use an aur helper),
+# there's no need to manually change pkgver.
# Please don't flag out-of-date!
pkgname=atom-editor-git
pkgver=v1.0.7.r46.g927ec7a
@@ -26,7 +27,7 @@ md5sums=('SKIP'
pkgver() {
cd "$srcdir/atom"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
prepare() {