summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2021-02-28 23:49:58 -0500
committersolaraquarion2021-02-28 23:49:58 -0500
commit2b112137b6e010e7898e9581bf7db4e8c9cc8f98 (patch)
treeb59c13b2968a8ba4dbf8c7da95f71befad738f67
parente6a381534c393b62487e515c97f68c83ff2ec925 (diff)
downloadaur-2b112137b6e010e7898e9581bf7db4e8c9cc8f98.tar.gz
electron 6 and whatever
-rw-r--r--PKGBUILD11
-rw-r--r--atom.js2
-rw-r--r--fix-atom-sh.patch4
3 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25afa77c1bcf..9c44754d947c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_name=atom
pkgname=atom-editor-git
pkgver=1.56.0.dev.r53.g3d5c83be9
-pkgrel=1
+pkgrel=2
pkgdesc='Hackable text editor for the 21st Century - git channel'
arch=('x86_64')
url="https://atom.io/"
@@ -31,9 +31,9 @@ source=("git+https://github.com/atom/atom.git"
'use-system-apm.patch'
'use-system-electron.patch')
sha256sums=('SKIP'
- '6218ecf9a767e80f70a4b07abaefcf63a3d615200ff27b2dbc7bb36eacd8e87f'
+ '6ae4f78667a8735d24ba11a47f1ee374f65325a3d604bcd221d56e27e16ddad4'
'530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153'
- 'b739d15a3b0964b979b4007a15451358bd5cea6f157ffdd475869907e8943f6c'
+ '5c0b189b842b88cd76b287a1def3c877ce63c2dc34cb972644e1eeb8bb5f4b3d'
'2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1'
'e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076'
'e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8'
@@ -101,11 +101,6 @@ build() {
cd script
npm install
-
- cd script-runner
- npm install
-
- cd ..
# Set ELECTRON_VERSION (see use-system-electron.patch)
env \
ELECTRON_RUN_AS_NODE=1 \
diff --git a/atom.js b/atom.js
index c3efd46e391e..ce706eb9e807 100644
--- a/atom.js
+++ b/atom.js
@@ -1,4 +1,4 @@
-#!/usr/bin/electron5
+#!/usr/bin/electron6
const name = "atom";
diff --git a/fix-atom-sh.patch b/fix-atom-sh.patch
index 4a86bae098e7..68c66ec6e6f4 100644
--- a/fix-atom-sh.patch
+++ b/fix-atom-sh.patch
@@ -159,8 +159,8 @@ index 768ab72b9..8a564c1a1 100755
fi
+ ) &
fi
-
+
# Exits this process when Atom is used as $EDITOR
---
+--
2.30.1