summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2021-02-28 21:57:24 -0500
committersolaraquarion2021-02-28 21:57:24 -0500
commit2ddda87afc78f95f7e759d07bfe8ddc5aed55e49 (patch)
treecf998915ef7cc88e3619d7e96246a64a974abc34
parentcc10136e6acc9fd7a75d5fcca8c5f112c1fd3256 (diff)
downloadaur-2ddda87afc78f95f7e759d07bfe8ddc5aed55e49.tar.gz
reversions and updates
-rw-r--r--PKGBUILD17
-rw-r--r--use-system-apm.patch7
-rw-r--r--use-system-electron.patch15
3 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 601a7784ef62..25afa77c1bcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_name=atom
pkgname=atom-editor-git
-pkgver=1.56.0.dev.r365.g924b06347
+pkgver=1.56.0.dev.r53.g3d5c83be9
pkgrel=1
pkgdesc='Hackable text editor for the 21st Century - git channel'
arch=('x86_64')
@@ -30,9 +30,18 @@ source=("git+https://github.com/atom/atom.git"
'symbols-view-use-system-ctags.patch'
'use-system-apm.patch'
'use-system-electron.patch')
-==== BASE ====
-sha256sums=('SKIP')
-==== BASE ====
+sha256sums=('SKIP'
+ '6218ecf9a767e80f70a4b07abaefcf63a3d615200ff27b2dbc7bb36eacd8e87f'
+ '530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153'
+ 'b739d15a3b0964b979b4007a15451358bd5cea6f157ffdd475869907e8943f6c'
+ '2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1'
+ 'e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076'
+ 'e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8'
+ '40d783794d62f12f3c429c624a84265871c7ed95f4120c9db800348896dd5437'
+ 'a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b'
+ '3c68e6b3751313e1d386e721f8f819fb051351fb2cf8e753b1d773a0f475fef8'
+ '08ae0c93b5ec7eb7d90c65d5d2adbaca538482fba902ed1f8414024db0d21854'
+ '0f809f3d2fb21e83ede312660c9169e239c874b0d7ed39e1c15301f6ce1ea056')
pkgver() {
cd ${_name}
diff --git a/use-system-apm.patch b/use-system-apm.patch
index 9cbcf8c75fb6..ef6aca470709 100644
--- a/use-system-apm.patch
+++ b/use-system-apm.patch
@@ -1,12 +1,9 @@
--- a/script/lib/run-apm-install.js
+++ b/script/lib/run-apm-install.js
-@@ -8,10 +8,7 @@
- const installEnv = Object.assign({}, process.env);
+@@ -9,7 +9,7 @@
// Set resource path so that apm can load metadata related to Atom.
installEnv.ATOM_RESOURCE_PATH = CONFIG.repositoryRootPath;
-- // Set our target (Electron) version so that node-pre-gyp can download the
-- // proper binaries.
-- installEnv.npm_config_target = CONFIG.appMetadata.electronVersion;
+
- childProcess.execFileSync(CONFIG.getApmBinPath(), [ci ? 'ci' : 'install'], {
+ childProcess.execFileSync('apm', [ci ? 'ci' : 'install'], {
env: installEnv,
diff --git a/use-system-electron.patch b/use-system-electron.patch
index f56e65ec8c5f..fe48f3ff8518 100644
--- a/use-system-electron.patch
+++ b/use-system-electron.patch
@@ -19,10 +19,10 @@
const cleanOutputDirectory = require('./lib/clean-output-directory')
const codeSignOnMac = require('./lib/code-sign-on-mac')
const codeSignOnWindows = require('./lib/code-sign-on-windows')
-@@ -64,12 +64,12 @@
- })
-
+@@ -66,12 +66,12 @@
const CONFIG = require('./config')
+
+ // Used by the 'github' package for Babel configuration
-process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
+// process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
@@ -34,7 +34,7 @@
cleanOutputDirectory()
copyAssets()
transpilePackagesWithCustomTranspilerPaths()
-@@ -88,74 +88,5 @@
+@@ -90,74 +90,5 @@
if (!argv.generateApiDocs) {
binariesPromise
@@ -140,12 +140,12 @@
};
--- a/script/package.json
+++ b/script/package.json
-@@ -10,9 +10,7 @@
+@@ -12,9 +12,7 @@
"coffeelint": "1.15.7",
"colors": "1.1.2",
"donna": "1.0.16",
- "electron-chromedriver": "^9.0.0",
- "electron-link": "0.4.1",
+ "electron-link": "^0.4.3",
- "electron-mksnapshot": "^9.0.2",
"electron-packager": "^15.0.0",
"eslint": "^5.16.0",
@@ -174,7 +174,7 @@
const atomJsPath = path.join(cache.resourcePath, 'exports', 'atom.js');
--- a/src/package-manager.js
+++ b/src/package-manager.js
-@@ -939,7 +939,7 @@
+@@ -949,7 +949,7 @@
isBundledPackagePath(packagePath) {
if (
this.devMode &&
@@ -214,4 +214,3 @@
const ModuleCache = useSnapshot
? snapshotResult.customRequire('../src/module-cache.js')
-