summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2021-02-28 19:41:02 -0500
committersolaraquarion2021-02-28 19:41:02 -0500
commit41957936c25bffa01dc0d723320a52b11d66f77e (patch)
treeaca95bc5c1f94c912cccbe1fcea0f84c8481f5da
parent49dda0eb05df1c804f22e7036cb262f0e339b506 (diff)
downloadaur-41957936c25bffa01dc0d723320a52b11d66f77e.tar.gz
moving to atom-community and fixing most of the build issues
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--fix-atom-sh.patch16
-rw-r--r--use-system-apm.patch21
-rw-r--r--use-system-electron.patch107
5 files changed, 136 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d627d3c9cea8..8fc0d52bcadb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = atom-editor-git
pkgdesc = Hackable text editor for the 21st Century - git channel
- pkgver = 1.35.0.r1386.g527af1ad3
+ pkgver = 1.35.0.r2223.g924b06347
pkgrel = 1
url = https://atom.io/
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = atom-editor-git
makedepends = nodejs
makedepends = libsecret
makedepends = python
- depends = apm
+ depends = apm-community
depends = electron6
depends = libxkbfile
depends = ripgrep
@@ -21,7 +21,7 @@ pkgbase = atom-editor-git
provides = atom
conflicts = atom
options = !emptydirs
- source = git+https://github.com/atom/atom.git
+ source = git+https://github.com/atom-community/atom.git
source = atom.js
source = dugite-use-system-git.patch
source = fix-atom-sh.patch
@@ -34,5 +34,16 @@ pkgbase = atom-editor-git
source = use-system-apm.patch
source = use-system-electron.patch
sha256sums = SKIP
+ sha256sums = 6ae4f78667a8735d24ba11a47f1ee374f65325a3d604bcd221d56e27e16ddad4
+ sha256sums = 530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153
+ sha256sums = b739d15a3b0964b979b4007a15451358bd5cea6f157ffdd475869907e8943f6c
+ sha256sums = 2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1
+ sha256sums = e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076
+ sha256sums = e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8
+ sha256sums = 40d783794d62f12f3c429c624a84265871c7ed95f4120c9db800348896dd5437
+ sha256sums = a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b
+ sha256sums = c93cc88dd704388d4b26a0de0a5938df7ff90cedf8eed0b3b8a675f9cc7d487c
+ sha256sums = 510f9986f687251b34338495eabde2c79a31b90f5ecca3f120bf4e6f34974010
+ sha256sums = 25875f16768d2b3f9b823de4e8760d65b519966570b38cd2a067de340d587ec1
pkgname = atom-editor-git
diff --git a/PKGBUILD b/PKGBUILD
index 371f3144d79b..c437ec2e0a6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,20 @@
_name=atom
pkgname=atom-editor-git
-pkgver=1.35.0.r1386.g527af1ad3
+pkgver=1.35.0.r2223.g924b06347
pkgrel=1
pkgdesc='Hackable text editor for the 21st Century - git channel'
arch=('x86_64')
url="https://atom.io/"
license=('MIT' 'custom')
-depends=('apm' 'electron6' 'libxkbfile' 'ripgrep')
+depends=('apm-community' 'electron6' 'libxkbfile' 'ripgrep')
makedepends=('git' 'npm' 'gconf' 'nodejs' 'libsecret' 'python')
optdepends=('ctags: symbol indexing support'
'git: Git and GitHub integration')
conflicts=('atom')
provides=('atom')
options=(!emptydirs)
-source=("git+https://github.com/atom/atom.git"
+source=("git+https://github.com/atom-community/atom.git"
'atom.js'
'dugite-use-system-git.patch'
'fix-atom-sh.patch'
@@ -31,7 +31,18 @@ source=("git+https://github.com/atom/atom.git"
'symbols-view-use-system-ctags.patch'
'use-system-apm.patch'
'use-system-electron.patch')
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ '6ae4f78667a8735d24ba11a47f1ee374f65325a3d604bcd221d56e27e16ddad4'
+ '530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153'
+ 'b739d15a3b0964b979b4007a15451358bd5cea6f157ffdd475869907e8943f6c'
+ '2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1'
+ 'e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076'
+ 'e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8'
+ '40d783794d62f12f3c429c624a84265871c7ed95f4120c9db800348896dd5437'
+ 'a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b'
+ 'c93cc88dd704388d4b26a0de0a5938df7ff90cedf8eed0b3b8a675f9cc7d487c'
+ '510f9986f687251b34338495eabde2c79a31b90f5ecca3f120bf4e6f34974010'
+ '25875f16768d2b3f9b823de4e8760d65b519966570b38cd2a067de340d587ec1')
pkgver() {
cd ${_name}
@@ -84,12 +95,16 @@ build() {
cd script
npm install
- # Hack to avoid using Node > 12 (https://github.com/babel/babel/issues/11216)
+
+ cd script-runner
+ npm install
+
+ cd ..
# Set ELECTRON_VERSION (see use-system-electron.patch)
env \
ELECTRON_RUN_AS_NODE=1 \
ELECTRON_VERSION=$(< /usr/lib/electron6/version) \
- electron5 \
+ electron6 \
build --no-bootstrap
}
diff --git a/fix-atom-sh.patch b/fix-atom-sh.patch
index 98d294918a28..4a86bae098e7 100644
--- a/fix-atom-sh.patch
+++ b/fix-atom-sh.patch
@@ -1,3 +1,14 @@
+From cea80c4b9c95ed0c4268eb8e248965bc4f4c8b24 Mon Sep 17 00:00:00 2001
+From: solaraquarion <shlomochoina@gmail.com>
+Date: Sun, 28 Feb 2021 17:54:05 -0500
+Subject: [PATCH 1/3] fix atom sh
+
+---
+ atom.sh | 133 ++++++--------------------------------------------------
+ 1 file changed, 14 insertions(+), 119 deletions(-)
+
+diff --git a/atom.sh b/atom.sh
+index 768ab72b9..8a564c1a1 100755
--- a/atom.sh
+++ b/atom.sh
@@ -1,29 +1,5 @@
@@ -30,7 +41,7 @@
# Only set the ATOM_DISABLE_SHELLING_OUT_FOR_ENVIRONMENT env var if it hasn't been set.
if [ -z "$ATOM_DISABLE_SHELLING_OUT_FOR_ENVIRONMENT" ]
then
-@@ -90,105 +66,24 @@
+@@ -90,105 +66,24 @@ fi
ATOM_HOME="${ATOM_HOME:-$HOME/.atom}"
mkdir -p "$ATOM_HOME"
@@ -150,3 +161,6 @@
fi
# Exits this process when Atom is used as $EDITOR
+--
+2.30.1
+
diff --git a/use-system-apm.patch b/use-system-apm.patch
index ef6aca470709..428973ad1fbf 100644
--- a/use-system-apm.patch
+++ b/use-system-apm.patch
@@ -1,6 +1,18 @@
+From 53b8342d6e4f89e63f2e7a31481fc52b2868224b Mon Sep 17 00:00:00 2001
+From: solaraquarion <shlomochoina@gmail.com>
+Date: Sun, 28 Feb 2021 19:14:47 -0500
+Subject: [PATCH 3/3] use system apm
+
+---
+ script/lib/run-apm-install.js | 2 +-
+ src/package-manager.js | 14 +-------------
+ 2 files changed, 2 insertions(+), 14 deletions(-)
+
+diff --git a/script/lib/run-apm-install.js b/script/lib/run-apm-install.js
+index f582ff471..72bec210c 100644
--- a/script/lib/run-apm-install.js
+++ b/script/lib/run-apm-install.js
-@@ -9,7 +9,7 @@
+@@ -9,7 +9,7 @@ module.exports = function(packagePath, ci, stdioOptions) {
// Set resource path so that apm can load metadata related to Atom.
installEnv.ATOM_RESOURCE_PATH = CONFIG.repositoryRootPath;
@@ -9,9 +21,11 @@
env: installEnv,
cwd: packagePath,
stdio: stdioOptions || 'inherit'
+diff --git a/src/package-manager.js b/src/package-manager.js
+index 775916ad6..a75b84ea4 100644
--- a/src/package-manager.js
+++ b/src/package-manager.js
-@@ -194,19 +194,7 @@
+@@ -194,19 +194,7 @@ module.exports = class PackageManager {
return configPath || this.apmPath;
}
@@ -32,3 +46,6 @@
}
// Public: Get the paths being used to look for packages.
+--
+2.30.1
+
diff --git a/use-system-electron.patch b/use-system-electron.patch
index fe48f3ff8518..8419691f8390 100644
--- a/use-system-electron.patch
+++ b/use-system-electron.patch
@@ -1,3 +1,22 @@
+From b482cc7b1a4c97e39f2643dba92b5a7dfdde0bcd Mon Sep 17 00:00:00 2001
+From: solaraquarion <shlomochoina@gmail.com>
+Date: Sun, 28 Feb 2021 18:50:11 -0500
+Subject: [PATCH 2/3] use system electron
+
+---
+ package.json | 1 -
+ script/build | 64 ++-----------------------
+ script/lib/generate-startup-snapshot.js | 8 ++--
+ script/package.json | 2 -
+ src/compile-cache.js | 2 +-
+ src/module-cache.js | 2 +-
+ src/package-manager.js | 2 +-
+ src/task-bootstrap.js | 2 +-
+ static/index.js | 4 +-
+ 9 files changed, 12 insertions(+), 75 deletions(-)
+
+diff --git a/package.json b/package.json
+index 79f105c99..4df7b2753 100644
--- a/package.json
+++ b/package.json
@@ -12,7 +12,6 @@
@@ -8,39 +27,33 @@
"dependencies": {
"@atom/nsfw": "1.0.26",
"@atom/source-map-support": "^0.3.4",
+diff --git a/script/build b/script/build
+index 7e2ae319c..9ae039c60 100755
--- a/script/build
+++ b/script/build
-@@ -33,7 +33,7 @@
+@@ -37,7 +37,7 @@ const argv = yargs
.wrap(yargs.terminalWidth())
.argv
-const checkChromedriverVersion = require('./lib/check-chromedriver-version')
-+// const checkChromedriverVersion = require('./lib/check-chromedriver-version')
++//const checkChromedriverVersion = require('./lib/check-chromedriver-version')
const cleanOutputDirectory = require('./lib/clean-output-directory')
const codeSignOnMac = require('./lib/code-sign-on-mac')
const codeSignOnWindows = require('./lib/code-sign-on-windows')
-@@ -66,12 +66,12 @@
- const CONFIG = require('./config')
+@@ -62,7 +62,7 @@ process.on('unhandledRejection', function (e) {
+ process.exit(1)
+ })
- // Used by the 'github' package for Babel configuration
-process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
-+// process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
++//process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
- let binariesPromise = Promise.resolve()
-
- if (!argv.existingBinaries) {
-- checkChromedriverVersion()
-+ // checkChromedriverVersion()
- cleanOutputDirectory()
- copyAssets()
- transpilePackagesWithCustomTranspilerPaths()
-@@ -90,74 +90,5 @@
+ async function transpile() {
+ const { spawn, Thread, Worker } = require(`${CONFIG.scriptRunnerModulesPath}/threads`)
+@@ -98,68 +98,10 @@ async function transpile() {
+ await Thread.terminate(transpilePegJsPaths)
+ }
- if (!argv.generateApiDocs) {
- binariesPromise
-- .then(packageApplication)
- .then(packagedAppPath => generateStartupSnapshot(packagedAppPath).then(() => packagedAppPath))
-- .then(async packagedAppPath => {
+-async function singAndCreateInstaller(packagedAppPath) {
- switch (process.platform) {
- case 'darwin': {
- if (argv.codeSign) {
@@ -95,23 +108,22 @@
- }
-
- return Promise.resolve(packagedAppPath)
-- }).then(packagedAppPath => {
-- if (argv.compressArtifacts) {
-- compressArtifacts(packagedAppPath)
-- } else {
-- console.log('Skipping artifacts compression. Specify the --compress-artifacts option to compress Atom binaries (and symbols on macOS)'.gray)
-- }
+-}
-
-- if (argv.install != null) {
-- installApplication(packagedAppPath, argv.install)
-- } else {
-- console.log('Skipping installation. Specify the --install option to install Atom'.gray)
-- }
-- })
- }
+-
+ async function build() {
+
+ if (!argv.existingBinaries) {
+- checkChromedriverVersion()
++ // checkChromedriverVersion()
+ await cleanOutputDirectory()
+ await copyAssets()
+ await transpile()
+diff --git a/script/lib/generate-startup-snapshot.js b/script/lib/generate-startup-snapshot.js
+index 41d2b7281..b05cbbd26 100644
--- a/script/lib/generate-startup-snapshot.js
+++ b/script/lib/generate-startup-snapshot.js
-@@ -286,17 +286,14 @@
+@@ -288,17 +288,14 @@ module.exports = function(packagedAppPath) {
CONFIG.executableName
);
} else {
@@ -127,17 +139,19 @@
{ env: Object.assign({}, process.env, { ELECTRON_RUN_AS_NODE: 1 }) }
);
-
-+ /*
++/*
console.log('Generating startup blob with mksnapshot');
childProcess.spawnSync(process.execPath, [
path.join(
-@@ -338,5 +335,6 @@
+@@ -340,5 +337,6 @@ module.exports = function(packagedAppPath) {
destinationPath
);
}
+ */
});
};
+diff --git a/script/package.json b/script/package.json
+index d2aa282a9..013a9e46b 100644
--- a/script/package.json
+++ b/script/package.json
@@ -12,9 +12,7 @@
@@ -145,11 +159,13 @@
"colors": "1.1.2",
"donna": "1.0.16",
- "electron-chromedriver": "^9.0.0",
- "electron-link": "^0.4.3",
+ "electron-link": "npm:@aminya/electron-link@^0.6.3",
- "electron-mksnapshot": "^9.0.2",
"electron-packager": "^15.0.0",
"eslint": "^5.16.0",
"eslint-config-prettier": "^4.2.0",
+diff --git a/src/compile-cache.js b/src/compile-cache.js
+index 2e35760ff..1f1b296a4 100644
--- a/src/compile-cache.js
+++ b/src/compile-cache.js
@@ -138,7 +138,7 @@ exports.install = function(resourcesPath, nodeRequire) {
@@ -161,9 +177,11 @@
name: null
};
}
+diff --git a/src/module-cache.js b/src/module-cache.js
+index a63b3bbb3..66eb4972e 100644
--- a/src/module-cache.js
+++ b/src/module-cache.js
-@@ -270,7 +270,7 @@
+@@ -270,7 +270,7 @@ function resolveModulePath(relativePath, parentModule) {
function registerBuiltins(devMode) {
if (
devMode ||
@@ -172,9 +190,11 @@
) {
const fs = require('fs-plus');
const atomJsPath = path.join(cache.resourcePath, 'exports', 'atom.js');
+diff --git a/src/package-manager.js b/src/package-manager.js
+index 4e1bd5a29..775916ad6 100644
--- a/src/package-manager.js
+++ b/src/package-manager.js
-@@ -949,7 +949,7 @@
+@@ -949,7 +949,7 @@ module.exports = class PackageManager {
isBundledPackagePath(packagePath) {
if (
this.devMode &&
@@ -183,9 +203,11 @@
) {
return false;
}
+diff --git a/src/task-bootstrap.js b/src/task-bootstrap.js
+index 1edbce8fa..1ff6271ec 100644
--- a/src/task-bootstrap.js
+++ b/src/task-bootstrap.js
-@@ -3,7 +3,7 @@
+@@ -3,7 +3,7 @@ const [compileCachePath, taskPath] = process.argv.slice(2);
const CompileCache = require('./compile-cache');
CompileCache.setCacheDirectory(compileCachePath);
@@ -194,6 +216,8 @@
const setupGlobals = function() {
global.attachEvent = function() {};
+diff --git a/static/index.js b/static/index.js
+index 75be58393..546cab9bd 100644
--- a/static/index.js
+++ b/static/index.js
@@ -40,7 +40,7 @@
@@ -214,3 +238,6 @@
const ModuleCache = useSnapshot
? snapshotResult.customRequire('../src/module-cache.js')
+--
+2.30.1
+