summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvenom2021-01-01 14:40:41 -0800
committervenom2021-01-01 14:40:41 -0800
commit49dda0eb05df1c804f22e7036cb262f0e339b506 (patch)
tree9480768e5d6dd586fcf6cd07bdee9130585b01d1
parentabe24c3d70bc88ddd42774c8006a7659ff23e484 (diff)
downloadaur-49dda0eb05df1c804f22e7036cb262f0e339b506.tar.gz
attempt to bring package up to date
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--atom.js2
-rw-r--r--symbols-view-use-system-ctags.patch9
-rw-r--r--use-system-apm.patch7
-rw-r--r--use-system-electron.patch22
6 files changed, 32 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 932a611b5f41..d627d3c9cea8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,12 @@ pkgbase = atom-editor-git
license = custom
makedepends = git
makedepends = npm
+ makedepends = gconf
+ makedepends = nodejs
+ makedepends = libsecret
+ makedepends = python
depends = apm
- depends = electron5
+ depends = electron6
depends = libxkbfile
depends = ripgrep
optdepends = ctags: symbol indexing support
@@ -30,17 +34,5 @@ pkgbase = atom-editor-git
source = use-system-apm.patch
source = use-system-electron.patch
sha256sums = SKIP
- sha256sums = 6218ecf9a767e80f70a4b07abaefcf63a3d615200ff27b2dbc7bb36eacd8e87f
- sha256sums = 530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153
- sha256sums = b3d3706519556a59ba557b695017c9debe8b23efe2782cdb440131520bc0540d
- sha256sums = 2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1
- sha256sums = e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076
- sha256sums = e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8
- sha256sums = 40d783794d62f12f3c429c624a84265871c7ed95f4120c9db800348896dd5437
- sha256sums = a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b
- sha256sums = 3c68e6b3751313e1d386e721f8f819fb051351fb2cf8e753b1d773a0f475fef8
- sha256sums = 8d48dca4571136375b325f4bf94ccfb996e90e57b7fdf83d53c1eb2e69b3b0d4
- sha256sums = 84b03b2e68d2f86cd963a2e9327698545a8a782895594cf2cc9a74531c5c7875
pkgname = atom-editor-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3c1a00282ff3..371f3144d79b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: EatMyVenom <eat.my.venomm@gmail.com>
# Contributor: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
# Contributor: Matheus de Alcantara <matheus.de.alcantara@gmail.com>
# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
@@ -11,8 +12,8 @@ pkgdesc='Hackable text editor for the 21st Century - git channel'
arch=('x86_64')
url="https://atom.io/"
license=('MIT' 'custom')
-depends=('apm' 'electron5' 'libxkbfile' 'ripgrep')
-makedepends=('git' 'npm')
+depends=('apm' 'electron6' 'libxkbfile' 'ripgrep')
+makedepends=('git' 'npm' 'gconf' 'nodejs' 'libsecret' 'python')
optdepends=('ctags: symbol indexing support'
'git: Git and GitHub integration')
conflicts=('atom')
@@ -30,19 +31,7 @@ source=("git+https://github.com/atom/atom.git"
'symbols-view-use-system-ctags.patch'
'use-system-apm.patch'
'use-system-electron.patch')
-sha256sums=('SKIP'
- '6218ecf9a767e80f70a4b07abaefcf63a3d615200ff27b2dbc7bb36eacd8e87f'
- '530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153'
- 'b3d3706519556a59ba557b695017c9debe8b23efe2782cdb440131520bc0540d'
- '2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1'
- 'e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076'
- 'e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8'
- '40d783794d62f12f3c429c624a84265871c7ed95f4120c9db800348896dd5437'
- 'a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b'
- '3c68e6b3751313e1d386e721f8f819fb051351fb2cf8e753b1d773a0f475fef8'
- '8d48dca4571136375b325f4bf94ccfb996e90e57b7fdf83d53c1eb2e69b3b0d4'
- '84b03b2e68d2f86cd963a2e9327698545a8a782895594cf2cc9a74531c5c7875')
-
+sha256sums=('SKIP')
pkgver() {
cd ${_name}
@@ -67,7 +56,7 @@ build() {
ATOM_RESOURCE_PATH="${PWD}" \
npm_config_build_from_source=true \
- npm_config_target=$(< /usr/lib/electron5/version) \
+ npm_config_target=$(< /usr/lib/electron6/version) \
apm install
# Use system ctags
@@ -89,7 +78,7 @@ build() {
env \
npm_config_disturl=https://electronjs.org/headers \
npm_config_runtime=electron \
- npm_config_target=$(< /usr/lib/electron5/version) \
+ npm_config_target=$(< /usr/lib/electron6/version) \
node-gyp rebuild
cd ../..
@@ -99,7 +88,7 @@ build() {
# Set ELECTRON_VERSION (see use-system-electron.patch)
env \
ELECTRON_RUN_AS_NODE=1 \
- ELECTRON_VERSION=$(< /usr/lib/electron5/version) \
+ ELECTRON_VERSION=$(< /usr/lib/electron6/version) \
electron5 \
build --no-bootstrap
}
diff --git a/atom.js b/atom.js
index c3efd46e391e..ce706eb9e807 100644
--- a/atom.js
+++ b/atom.js
@@ -1,4 +1,4 @@
-#!/usr/bin/electron5
+#!/usr/bin/electron6
const name = "atom";
diff --git a/symbols-view-use-system-ctags.patch b/symbols-view-use-system-ctags.patch
index cd9ff5e2dcd4..da03a67259cf 100644
--- a/symbols-view-use-system-ctags.patch
+++ b/symbols-view-use-system-ctags.patch
@@ -1,11 +1,14 @@
--- a/lib/tag-generator.js
+++ b/lib/tag-generator.js
-@@ -79,7 +79,7 @@ export default class TagGenerator {
+@@ -79,9 +79,8 @@
generate() {
let tags = {};
const packageRoot = this.getPackageRoot();
- const command = path.join(packageRoot, 'vendor', `ctags-${process.platform}`);
+- const defaultCtagsFile = path.join(packageRoot, 'lib', 'ctags-config');
+- const args = [`--options=${defaultCtagsFile}`, '--fields=+KS'];
+ const command = 'ctags';
- const defaultCtagsFile = path.join(packageRoot, 'lib', 'ctags-config');
- const args = [`--options=${defaultCtagsFile}`, '--fields=+KS'];
++ const args = ['--fields=+KS'];
+ if (atom.config.get('symbols-view.useEditorGrammarAsCtagsLanguage')) {
+ const language = this.getLanguage();
diff --git a/use-system-apm.patch b/use-system-apm.patch
index 9cbcf8c75fb6..ef6aca470709 100644
--- a/use-system-apm.patch
+++ b/use-system-apm.patch
@@ -1,12 +1,9 @@
--- a/script/lib/run-apm-install.js
+++ b/script/lib/run-apm-install.js
-@@ -8,10 +8,7 @@
- const installEnv = Object.assign({}, process.env);
+@@ -9,7 +9,7 @@
// Set resource path so that apm can load metadata related to Atom.
installEnv.ATOM_RESOURCE_PATH = CONFIG.repositoryRootPath;
-- // Set our target (Electron) version so that node-pre-gyp can download the
-- // proper binaries.
-- installEnv.npm_config_target = CONFIG.appMetadata.electronVersion;
+
- childProcess.execFileSync(CONFIG.getApmBinPath(), [ci ? 'ci' : 'install'], {
+ childProcess.execFileSync('apm', [ci ? 'ci' : 'install'], {
env: installEnv,
diff --git a/use-system-electron.patch b/use-system-electron.patch
index dddac2b8cc89..fe48f3ff8518 100644
--- a/use-system-electron.patch
+++ b/use-system-electron.patch
@@ -4,7 +4,7 @@
"url": "https://github.com/atom/atom/issues"
},
"license": "MIT",
-- "electronVersion": "5.0.13",
+- "electronVersion": "6.1.12",
"dependencies": {
"@atom/nsfw": "1.0.26",
"@atom/source-map-support": "^0.3.4",
@@ -19,10 +19,10 @@
const cleanOutputDirectory = require('./lib/clean-output-directory')
const codeSignOnMac = require('./lib/code-sign-on-mac')
const codeSignOnWindows = require('./lib/code-sign-on-windows')
-@@ -64,12 +64,12 @@
- })
-
+@@ -66,12 +66,12 @@
const CONFIG = require('./config')
+
+ // Used by the 'github' package for Babel configuration
-process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
+// process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
@@ -34,7 +34,7 @@
cleanOutputDirectory()
copyAssets()
transpilePackagesWithCustomTranspilerPaths()
-@@ -88,74 +88,5 @@
+@@ -90,74 +90,5 @@
if (!argv.generateApiDocs) {
binariesPromise
@@ -119,7 +119,7 @@
- packagedAppPath,
- CONFIG.executableName
- );
-+ nodeBundledInElectronPath = 'electron5';
++ nodeBundledInElectronPath = 'electron6';
}
childProcess.execFileSync(
nodeBundledInElectronPath,
@@ -140,16 +140,16 @@
};
--- a/script/package.json
+++ b/script/package.json
-@@ -10,9 +10,7 @@
+@@ -12,9 +12,7 @@
"coffeelint": "1.15.7",
"colors": "1.1.2",
"donna": "1.0.16",
- "electron-chromedriver": "^9.0.0",
- "electron-link": "0.4.1",
+ "electron-link": "^0.4.3",
- "electron-mksnapshot": "^9.0.2",
- "electron-packager": "12.2.0",
- "@atom/electron-winstaller": "0.0.1",
+ "electron-packager": "^15.0.0",
"eslint": "^5.16.0",
+ "eslint-config-prettier": "^4.2.0",
--- a/src/compile-cache.js
+++ b/src/compile-cache.js
@@ -138,7 +138,7 @@ exports.install = function(resourcesPath, nodeRequire) {
@@ -174,7 +174,7 @@
const atomJsPath = path.join(cache.resourcePath, 'exports', 'atom.js');
--- a/src/package-manager.js
+++ b/src/package-manager.js
-@@ -939,7 +939,7 @@
+@@ -949,7 +949,7 @@
isBundledPackagePath(packagePath) {
if (
this.devMode &&