summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2021-02-28 21:50:59 -0500
committersolaraquarion2021-02-28 21:50:59 -0500
commitcc10136e6acc9fd7a75d5fcca8c5f112c1fd3256 (patch)
treec55c230ad2d43e746d697ee18ebd97a62f51909e
parent18124e22e8e846852643001999e9092c39784a4d (diff)
downloadaur-cc10136e6acc9fd7a75d5fcca8c5f112c1fd3256.tar.gz
Revert "attempt to bring package up to date"
This reverts commit 49dda0eb05df1c804f22e7036cb262f0e339b506.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--atom.js2
-rw-r--r--symbols-view-use-system-ctags.patch9
-rw-r--r--use-system-apm.patch26
-rw-r--r--use-system-electron.patch106
6 files changed, 63 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17626889c3fa..c4231985315b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = atom-editor-git
makedepends = nodejs
makedepends = libsecret
makedepends = python
- depends = apm-community
+ depends = apm
depends = electron6
depends = libxkbfile
depends = ripgrep
@@ -21,7 +21,7 @@ pkgbase = atom-editor-git
provides = atom
conflicts = atom
options = !emptydirs
- source = git+https://github.com/atom-community/atom.git
+ source = git+https://github.com/atom/atom.git
source = atom.js
source = dugite-use-system-git.patch
source = fix-atom-sh.patch
@@ -34,16 +34,17 @@ pkgbase = atom-editor-git
source = use-system-apm.patch
source = use-system-electron.patch
sha256sums = SKIP
- sha256sums = 6ae4f78667a8735d24ba11a47f1ee374f65325a3d604bcd221d56e27e16ddad4
+ sha256sums = 6218ecf9a767e80f70a4b07abaefcf63a3d615200ff27b2dbc7bb36eacd8e87f
sha256sums = 530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153
- sha256sums = b739d15a3b0964b979b4007a15451358bd5cea6f157ffdd475869907e8943f6c
+ sha256sums = b3d3706519556a59ba557b695017c9debe8b23efe2782cdb440131520bc0540d
sha256sums = 2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1
sha256sums = e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076
sha256sums = e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8
sha256sums = 40d783794d62f12f3c429c624a84265871c7ed95f4120c9db800348896dd5437
sha256sums = a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b
- sha256sums = c93cc88dd704388d4b26a0de0a5938df7ff90cedf8eed0b3b8a675f9cc7d487c
- sha256sums = 510f9986f687251b34338495eabde2c79a31b90f5ecca3f120bf4e6f34974010
- sha256sums = 25875f16768d2b3f9b823de4e8760d65b519966570b38cd2a067de340d587ec1
+ sha256sums = 3c68e6b3751313e1d386e721f8f819fb051351fb2cf8e753b1d773a0f475fef8
+ sha256sums = 8d48dca4571136375b325f4bf94ccfb996e90e57b7fdf83d53c1eb2e69b3b0d4
+ sha256sums = 84b03b2e68d2f86cd963a2e9327698545a8a782895594cf2cc9a74531c5c7875
pkgname = atom-editor-git
+
diff --git a/PKGBUILD b/PKGBUILD
index 1e0f39faca93..601a7784ef62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# Maintainer: EatMyVenom <eat.my.venomm@gmail.com>
# Contributor: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
# Contributor: Matheus de Alcantara <matheus.de.alcantara@gmail.com>
# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
@@ -12,14 +11,14 @@ pkgdesc='Hackable text editor for the 21st Century - git channel'
arch=('x86_64')
url="https://atom.io/"
license=('MIT' 'custom')
-depends=('apm-community' 'electron6' 'libxkbfile' 'ripgrep')
+depends=('apm' 'electron6' 'libxkbfile' 'ripgrep')
makedepends=('git' 'npm' 'gconf' 'nodejs' 'libsecret' 'python')
optdepends=('ctags: symbol indexing support'
'git: Git and GitHub integration')
conflicts=('atom')
provides=('atom')
options=(!emptydirs)
-source=("git+https://github.com/atom-community/atom.git"
+source=("git+https://github.com/atom/atom.git"
'atom.js'
'dugite-use-system-git.patch'
'fix-atom-sh.patch'
@@ -31,18 +30,9 @@ source=("git+https://github.com/atom-community/atom.git"
'symbols-view-use-system-ctags.patch'
'use-system-apm.patch'
'use-system-electron.patch')
-sha256sums=('SKIP'
- '6ae4f78667a8735d24ba11a47f1ee374f65325a3d604bcd221d56e27e16ddad4'
- '530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153'
- 'b739d15a3b0964b979b4007a15451358bd5cea6f157ffdd475869907e8943f6c'
- '2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1'
- 'e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076'
- 'e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8'
- '40d783794d62f12f3c429c624a84265871c7ed95f4120c9db800348896dd5437'
- 'a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b'
- 'c93cc88dd704388d4b26a0de0a5938df7ff90cedf8eed0b3b8a675f9cc7d487c'
- '510f9986f687251b34338495eabde2c79a31b90f5ecca3f120bf4e6f34974010'
- '25875f16768d2b3f9b823de4e8760d65b519966570b38cd2a067de340d587ec1')
+==== BASE ====
+sha256sums=('SKIP')
+==== BASE ====
pkgver() {
cd ${_name}
diff --git a/atom.js b/atom.js
index ce706eb9e807..c3efd46e391e 100644
--- a/atom.js
+++ b/atom.js
@@ -1,4 +1,4 @@
-#!/usr/bin/electron6
+#!/usr/bin/electron5
const name = "atom";
diff --git a/symbols-view-use-system-ctags.patch b/symbols-view-use-system-ctags.patch
index da03a67259cf..cd9ff5e2dcd4 100644
--- a/symbols-view-use-system-ctags.patch
+++ b/symbols-view-use-system-ctags.patch
@@ -1,14 +1,11 @@
--- a/lib/tag-generator.js
+++ b/lib/tag-generator.js
-@@ -79,9 +79,8 @@
+@@ -79,7 +79,7 @@ export default class TagGenerator {
generate() {
let tags = {};
const packageRoot = this.getPackageRoot();
- const command = path.join(packageRoot, 'vendor', `ctags-${process.platform}`);
-- const defaultCtagsFile = path.join(packageRoot, 'lib', 'ctags-config');
-- const args = [`--options=${defaultCtagsFile}`, '--fields=+KS'];
+ const command = 'ctags';
-+ const args = ['--fields=+KS'];
+ const defaultCtagsFile = path.join(packageRoot, 'lib', 'ctags-config');
+ const args = [`--options=${defaultCtagsFile}`, '--fields=+KS'];
- if (atom.config.get('symbols-view.useEditorGrammarAsCtagsLanguage')) {
- const language = this.getLanguage();
diff --git a/use-system-apm.patch b/use-system-apm.patch
index 428973ad1fbf..9cbcf8c75fb6 100644
--- a/use-system-apm.patch
+++ b/use-system-apm.patch
@@ -1,31 +1,20 @@
-From 53b8342d6e4f89e63f2e7a31481fc52b2868224b Mon Sep 17 00:00:00 2001
-From: solaraquarion <shlomochoina@gmail.com>
-Date: Sun, 28 Feb 2021 19:14:47 -0500
-Subject: [PATCH 3/3] use system apm
-
----
- script/lib/run-apm-install.js | 2 +-
- src/package-manager.js | 14 +-------------
- 2 files changed, 2 insertions(+), 14 deletions(-)
-
-diff --git a/script/lib/run-apm-install.js b/script/lib/run-apm-install.js
-index f582ff471..72bec210c 100644
--- a/script/lib/run-apm-install.js
+++ b/script/lib/run-apm-install.js
-@@ -9,7 +9,7 @@ module.exports = function(packagePath, ci, stdioOptions) {
+@@ -8,10 +8,7 @@
+ const installEnv = Object.assign({}, process.env);
// Set resource path so that apm can load metadata related to Atom.
installEnv.ATOM_RESOURCE_PATH = CONFIG.repositoryRootPath;
-
+- // Set our target (Electron) version so that node-pre-gyp can download the
+- // proper binaries.
+- installEnv.npm_config_target = CONFIG.appMetadata.electronVersion;
- childProcess.execFileSync(CONFIG.getApmBinPath(), [ci ? 'ci' : 'install'], {
+ childProcess.execFileSync('apm', [ci ? 'ci' : 'install'], {
env: installEnv,
cwd: packagePath,
stdio: stdioOptions || 'inherit'
-diff --git a/src/package-manager.js b/src/package-manager.js
-index 775916ad6..a75b84ea4 100644
--- a/src/package-manager.js
+++ b/src/package-manager.js
-@@ -194,19 +194,7 @@ module.exports = class PackageManager {
+@@ -194,19 +194,7 @@
return configPath || this.apmPath;
}
@@ -46,6 +35,3 @@ index 775916ad6..a75b84ea4 100644
}
// Public: Get the paths being used to look for packages.
---
-2.30.1
-
diff --git a/use-system-electron.patch b/use-system-electron.patch
index 8419691f8390..f56e65ec8c5f 100644
--- a/use-system-electron.patch
+++ b/use-system-electron.patch
@@ -1,22 +1,3 @@
-From b482cc7b1a4c97e39f2643dba92b5a7dfdde0bcd Mon Sep 17 00:00:00 2001
-From: solaraquarion <shlomochoina@gmail.com>
-Date: Sun, 28 Feb 2021 18:50:11 -0500
-Subject: [PATCH 2/3] use system electron
-
----
- package.json | 1 -
- script/build | 64 ++-----------------------
- script/lib/generate-startup-snapshot.js | 8 ++--
- script/package.json | 2 -
- src/compile-cache.js | 2 +-
- src/module-cache.js | 2 +-
- src/package-manager.js | 2 +-
- src/task-bootstrap.js | 2 +-
- static/index.js | 4 +-
- 9 files changed, 12 insertions(+), 75 deletions(-)
-
-diff --git a/package.json b/package.json
-index 79f105c99..4df7b2753 100644
--- a/package.json
+++ b/package.json
@@ -12,7 +12,6 @@
@@ -27,33 +8,39 @@ index 79f105c99..4df7b2753 100644
"dependencies": {
"@atom/nsfw": "1.0.26",
"@atom/source-map-support": "^0.3.4",
-diff --git a/script/build b/script/build
-index 7e2ae319c..9ae039c60 100755
--- a/script/build
+++ b/script/build
-@@ -37,7 +37,7 @@ const argv = yargs
+@@ -33,7 +33,7 @@
.wrap(yargs.terminalWidth())
.argv
-const checkChromedriverVersion = require('./lib/check-chromedriver-version')
-+//const checkChromedriverVersion = require('./lib/check-chromedriver-version')
++// const checkChromedriverVersion = require('./lib/check-chromedriver-version')
const cleanOutputDirectory = require('./lib/clean-output-directory')
const codeSignOnMac = require('./lib/code-sign-on-mac')
const codeSignOnWindows = require('./lib/code-sign-on-windows')
-@@ -62,7 +62,7 @@ process.on('unhandledRejection', function (e) {
- process.exit(1)
+@@ -64,12 +64,12 @@
})
+ const CONFIG = require('./config')
-process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
-+//process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
++// process.env.ELECTRON_VERSION = CONFIG.appMetadata.electronVersion
- async function transpile() {
- const { spawn, Thread, Worker } = require(`${CONFIG.scriptRunnerModulesPath}/threads`)
-@@ -98,68 +98,10 @@ async function transpile() {
- await Thread.terminate(transpilePegJsPaths)
- }
+ let binariesPromise = Promise.resolve()
--async function singAndCreateInstaller(packagedAppPath) {
+ if (!argv.existingBinaries) {
+- checkChromedriverVersion()
++ // checkChromedriverVersion()
+ cleanOutputDirectory()
+ copyAssets()
+ transpilePackagesWithCustomTranspilerPaths()
+@@ -88,74 +88,5 @@
+
+ if (!argv.generateApiDocs) {
+ binariesPromise
+- .then(packageApplication)
+ .then(packagedAppPath => generateStartupSnapshot(packagedAppPath).then(() => packagedAppPath))
+- .then(async packagedAppPath => {
- switch (process.platform) {
- case 'darwin': {
- if (argv.codeSign) {
@@ -108,22 +95,23 @@ index 7e2ae319c..9ae039c60 100755
- }
-
- return Promise.resolve(packagedAppPath)
--}
--
+- }).then(packagedAppPath => {
+- if (argv.compressArtifacts) {
+- compressArtifacts(packagedAppPath)
+- } else {
+- console.log('Skipping artifacts compression. Specify the --compress-artifacts option to compress Atom binaries (and symbols on macOS)'.gray)
+- }
-
- async function build() {
-
- if (!argv.existingBinaries) {
-- checkChromedriverVersion()
-+ // checkChromedriverVersion()
- await cleanOutputDirectory()
- await copyAssets()
- await transpile()
-diff --git a/script/lib/generate-startup-snapshot.js b/script/lib/generate-startup-snapshot.js
-index 41d2b7281..b05cbbd26 100644
+- if (argv.install != null) {
+- installApplication(packagedAppPath, argv.install)
+- } else {
+- console.log('Skipping installation. Specify the --install option to install Atom'.gray)
+- }
+- })
+ }
--- a/script/lib/generate-startup-snapshot.js
+++ b/script/lib/generate-startup-snapshot.js
-@@ -288,17 +288,14 @@ module.exports = function(packagedAppPath) {
+@@ -286,17 +286,14 @@
CONFIG.executableName
);
} else {
@@ -139,33 +127,29 @@ index 41d2b7281..b05cbbd26 100644
{ env: Object.assign({}, process.env, { ELECTRON_RUN_AS_NODE: 1 }) }
);
-
-+/*
++ /*
console.log('Generating startup blob with mksnapshot');
childProcess.spawnSync(process.execPath, [
path.join(
-@@ -340,5 +337,6 @@ module.exports = function(packagedAppPath) {
+@@ -338,5 +335,6 @@
destinationPath
);
}
+ */
});
};
-diff --git a/script/package.json b/script/package.json
-index d2aa282a9..013a9e46b 100644
--- a/script/package.json
+++ b/script/package.json
-@@ -12,9 +12,7 @@
+@@ -10,9 +10,7 @@
"coffeelint": "1.15.7",
"colors": "1.1.2",
"donna": "1.0.16",
- "electron-chromedriver": "^9.0.0",
- "electron-link": "npm:@aminya/electron-link@^0.6.3",
+ "electron-link": "0.4.1",
- "electron-mksnapshot": "^9.0.2",
"electron-packager": "^15.0.0",
"eslint": "^5.16.0",
"eslint-config-prettier": "^4.2.0",
-diff --git a/src/compile-cache.js b/src/compile-cache.js
-index 2e35760ff..1f1b296a4 100644
--- a/src/compile-cache.js
+++ b/src/compile-cache.js
@@ -138,7 +138,7 @@ exports.install = function(resourcesPath, nodeRequire) {
@@ -177,11 +161,9 @@ index 2e35760ff..1f1b296a4 100644
name: null
};
}
-diff --git a/src/module-cache.js b/src/module-cache.js
-index a63b3bbb3..66eb4972e 100644
--- a/src/module-cache.js
+++ b/src/module-cache.js
-@@ -270,7 +270,7 @@ function resolveModulePath(relativePath, parentModule) {
+@@ -270,7 +270,7 @@
function registerBuiltins(devMode) {
if (
devMode ||
@@ -190,11 +172,9 @@ index a63b3bbb3..66eb4972e 100644
) {
const fs = require('fs-plus');
const atomJsPath = path.join(cache.resourcePath, 'exports', 'atom.js');
-diff --git a/src/package-manager.js b/src/package-manager.js
-index 4e1bd5a29..775916ad6 100644
--- a/src/package-manager.js
+++ b/src/package-manager.js
-@@ -949,7 +949,7 @@ module.exports = class PackageManager {
+@@ -939,7 +939,7 @@
isBundledPackagePath(packagePath) {
if (
this.devMode &&
@@ -203,11 +183,9 @@ index 4e1bd5a29..775916ad6 100644
) {
return false;
}
-diff --git a/src/task-bootstrap.js b/src/task-bootstrap.js
-index 1edbce8fa..1ff6271ec 100644
--- a/src/task-bootstrap.js
+++ b/src/task-bootstrap.js
-@@ -3,7 +3,7 @@ const [compileCachePath, taskPath] = process.argv.slice(2);
+@@ -3,7 +3,7 @@
const CompileCache = require('./compile-cache');
CompileCache.setCacheDirectory(compileCachePath);
@@ -216,8 +194,6 @@ index 1edbce8fa..1ff6271ec 100644
const setupGlobals = function() {
global.attachEvent = function() {};
-diff --git a/static/index.js b/static/index.js
-index 75be58393..546cab9bd 100644
--- a/static/index.js
+++ b/static/index.js
@@ -40,7 +40,7 @@
@@ -238,6 +214,4 @@ index 75be58393..546cab9bd 100644
const ModuleCache = useSnapshot
? snapshotResult.customRequire('../src/module-cache.js')
---
-2.30.1