summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilaFedotov2020-07-21 14:12:49 +0100
committerDanilaFedotov2020-07-21 14:12:49 +0100
commit1eab96e312f62f55b6523622f3e2b5471d285660 (patch)
treee52368f2493c0c714db0e7d099dcc5eb3975e19e
parentf4144bd08a33bfea7e39e9f0a5d77b25b1f16872 (diff)
downloadaur-1eab96e312f62f55b6523622f3e2b5471d285660.tar.gz
Updated to 1.49.0
-rw-r--r--PKGBUILD17
-rw-r--r--atom.js2
-rw-r--r--enable-transparency.patch8
-rw-r--r--fix-license-path.patch2
-rw-r--r--fix-restart.patch2
-rw-r--r--use-system-electron.patch35
6 files changed, 28 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03cc34044f9f..3d07753e8093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,21 +33,20 @@ source=("git+https://github.com/atom/atom.git#commit=${_commit}"
'use-system-electron.patch'
'enable-transparency.patch')
sha256sums=('SKIP'
- 'd286e0766e47cfea73cd207abb9d6f7375846688823e72732c871a852b4b261d'
+ '6218ecf9a767e80f70a4b07abaefcf63a3d615200ff27b2dbc7bb36eacd8e87f'
'530b46d31df0f5e8f5881e1608a66fe75d549092a6db2e72ba3ad69c48714153'
'b3d3706519556a59ba557b695017c9debe8b23efe2782cdb440131520bc0540d'
- '2894cce31935d45291c5fe4c625473bb83fc51e1b899f162aa6b419491c7ace1'
- 'e3c30c03006d23a72f07fa77f4309b16a6059af1179343033a87f74f50124076'
+ '74cd1d023ae1d1c9835006ea14cdd315649df2d5eb7996de664a45e720742daf'
+ '63ad62bef0be1029d5d10a4c76eeb6bafda4328288230e9393cd48659ec7cf2c'
'e321fdfe880cd465918dd1dbb90e4c7d46fc5310f20666eddf0a41cbca4f8ac8'
'40d783794d62f12f3c429c624a84265871c7ed95f4120c9db800348896dd5437'
'a09439c2a908ca174ff3be1f0d85071d12c792ae19748e36fe601e372d6d925b'
'3c68e6b3751313e1d386e721f8f819fb051351fb2cf8e753b1d773a0f475fef8'
'8d48dca4571136375b325f4bf94ccfb996e90e57b7fdf83d53c1eb2e69b3b0d4'
- '81af763f05c1afd87705b8c7a6647e35f524b2e952adb2e596de2a7e8fe4e69e'
- '2693e528c689b770ba976aeaba125e4b269a57a02294d3c3f2a0d85ed65a93eb')
-
+ '84b03b2e68d2f86cd963a2e9327698545a8a782895594cf2cc9a74531c5c7875'
+ '33d96efa4148f74c77f3c0fc447567c13543b0e6118b7622ae938cb2169203c6')
prepare() {
- cd ${pkgname}
+ cd "${srcdir}/atom"
patch -Np1 -i ../fix-atom-sh.patch
patch -Np1 -i ../use-system-electron.patch
@@ -60,7 +59,7 @@ prepare() {
}
build() {
- cd ${pkgname}
+ cd "${srcdir}/atom"
ATOM_RESOURCE_PATH="${PWD}" \
npm_config_build_from_source=true \
@@ -102,7 +101,7 @@ build() {
}
package() {
- cd ${pkgname}
+ cd "${srcdir}/atom"
install -d -m 755 "${pkgdir}"/usr/lib
cp -r out/app "${pkgdir}"/usr/lib/atom
diff --git a/atom.js b/atom.js
index f9c7e17d19c6..c3efd46e391e 100644
--- a/atom.js
+++ b/atom.js
@@ -1,4 +1,4 @@
-#!/usr/bin/electron4
+#!/usr/bin/electron5
const name = "atom";
diff --git a/enable-transparency.patch b/enable-transparency.patch
index 454e11ca13d4..d2d247127776 100644
--- a/enable-transparency.patch
+++ b/enable-transparency.patch
@@ -23,12 +23,14 @@ diff -ur a/atom.sh b/atom.sh
diff -ur a/src/main-process/atom-window.js b/src/main-process/atom-window.js
--- a/src/main-process/atom-window.js 2018-05-19 06:49:28.000000000 +0800
+++ b/src/main-process/atom-window.js 2018-06-03 20:18:09.254908066 +0800
-@@ -31,6 +31,8 @@
- this.closedPromise = new Promise(resolve => { this.resolveClosedPromise = resolve })
+@@ -33,8 +33,10 @@
+ this.closedPromise = new Promise(resolve => {
+ this.resolveClosedPromise = resolve;
+ });
const options = {
+ frame: false,
+ transparent: true,
show: false,
- title: 'Atom',
+ title: getAppName(),
tabbingIdentifier: 'atom',
diff --git a/fix-license-path.patch b/fix-license-path.patch
index ecffc1eb0cab..4cdcf55640a6 100644
--- a/fix-license-path.patch
+++ b/fix-license-path.patch
@@ -1,6 +1,6 @@
--- a/src/main-process/atom-application.js
+++ b/src/main-process/atom-application.js
-@@ -716,7 +716,7 @@
+@@ -711,7 +711,7 @@
);
this.openPathOnEvent(
'application:open-license',
diff --git a/fix-restart.patch b/fix-restart.patch
index c12d3346157f..f08748ed976f 100644
--- a/fix-restart.patch
+++ b/fix-restart.patch
@@ -1,6 +1,6 @@
--- a/src/main-process/atom-application.js
+++ b/src/main-process/atom-application.js
-@@ -2047,7 +2047,7 @@
+@@ -2042,7 +2042,7 @@
}
restart() {
diff --git a/use-system-electron.patch b/use-system-electron.patch
index 2cbc8b94e495..dddac2b8cc89 100644
--- a/use-system-electron.patch
+++ b/use-system-electron.patch
@@ -4,7 +4,7 @@
"url": "https://github.com/atom/atom/issues"
},
"license": "MIT",
-- "electronVersion": "4.2.7",
+- "electronVersion": "5.0.13",
"dependencies": {
"@atom/nsfw": "1.0.26",
"@atom/source-map-support": "^0.3.4",
@@ -19,7 +19,7 @@
const cleanOutputDirectory = require('./lib/clean-output-directory')
const codeSignOnMac = require('./lib/code-sign-on-mac')
const codeSignOnWindows = require('./lib/code-sign-on-windows')
-@@ -63,12 +63,12 @@
+@@ -64,12 +64,12 @@
})
const CONFIG = require('./config')
@@ -34,17 +34,18 @@
cleanOutputDirectory()
copyAssets()
transpilePackagesWithCustomTranspilerPaths()
-@@ -87,73 +87,5 @@
+@@ -88,74 +88,5 @@
if (!argv.generateApiDocs) {
binariesPromise
- .then(packageApplication)
.then(packagedAppPath => generateStartupSnapshot(packagedAppPath).then(() => packagedAppPath))
-- .then(packagedAppPath => {
+- .then(async packagedAppPath => {
- switch (process.platform) {
- case 'darwin': {
- if (argv.codeSign) {
-- codeSignOnMac(packagedAppPath)
+- await codeSignOnMac(packagedAppPath)
+- await notarizeOnMac(packagedAppPath)
- } else if (argv.testSign) {
- testSignOnMac(packagedAppPath)
- } else {
@@ -110,7 +111,7 @@
}
--- a/script/lib/generate-startup-snapshot.js
+++ b/script/lib/generate-startup-snapshot.js
-@@ -265,17 +265,14 @@
+@@ -286,17 +286,14 @@
CONFIG.executableName
);
} else {
@@ -118,7 +119,7 @@
- packagedAppPath,
- CONFIG.executableName
- );
-+ nodeBundledInElectronPath = 'electron4';
++ nodeBundledInElectronPath = 'electron5';
}
childProcess.execFileSync(
nodeBundledInElectronPath,
@@ -130,7 +131,7 @@
console.log('Generating startup blob with mksnapshot');
childProcess.spawnSync(process.execPath, [
path.join(
-@@ -317,5 +314,6 @@
+@@ -338,5 +335,6 @@
destinationPath
);
}
@@ -143,9 +144,9 @@
"coffeelint": "1.15.7",
"colors": "1.1.2",
"donna": "1.0.16",
-- "electron-chromedriver": "^4.2.0",
- "electron-link": "0.4.0",
-- "electron-mksnapshot": "^4.2.0",
+- "electron-chromedriver": "^9.0.0",
+ "electron-link": "0.4.1",
+- "electron-mksnapshot": "^9.0.2",
"electron-packager": "12.2.0",
"@atom/electron-winstaller": "0.0.1",
"eslint": "^5.16.0",
@@ -160,18 +161,6 @@
name: null
};
}
---- a/src/main-process/atom-window.js
-+++ b/src/main-process/atom-window.js
-@@ -47,7 +47,8 @@
- // Disable the `auxclick` feature so that `click` events are triggered in
- // response to a middle-click.
- // (Ref: https://github.com/atom/atom/pull/12696#issuecomment-290496960)
-- disableBlinkFeatures: 'Auxclick'
-+ disableBlinkFeatures: 'Auxclick',
-+ nodeIntegration: true
- }
- };
-
--- a/src/module-cache.js
+++ b/src/module-cache.js
@@ -270,7 +270,7 @@