summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-06-11 15:42:11 +0200
committerGoliathLabs2020-06-11 15:42:11 +0200
commit41d84d91f34654687cb6ac4d02479ebdbed56808 (patch)
treee3d2d3b10c1b140013a26b728cf9acf9a478f9ab
parent5067452ff1b3aa0c8b14b8a49a0377bf69f7f00b (diff)
downloadaur-41d84d91f34654687cb6ac4d02479ebdbed56808.tar.gz
Updated: 1.48.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7c3cdbf8e93..505f503ddbf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = atom-transparent
pkgdesc = A hackable text editor for the 21st Century, with transparency patch
- pkgver = 1.46.0
+ pkgver = 1.48.0
pkgrel = 1
url = https://github.com/atom/atom
arch = x86_64
@@ -9,15 +9,16 @@ pkgbase = atom-transparent
makedepends = git
makedepends = npm
depends = apm
- depends = electron4
+ depends = electron5
depends = libxkbfile
depends = ripgrep
optdepends = ctags: symbol indexing support
optdepends = git: Git and GitHub integration
provides = atom
conflicts = atom
+ replaces = atom-editor
options = !emptydirs
- source = git+https://github.com/atom/atom.git#commit=c1fea480e3f4f9c615e23c7da221deb9d3196005
+ source = git+https://github.com/atom/atom.git#commit=5df9cd3d774352321ffeb65570de77906792f8bc
source = atom.js
source = dugite-use-system-git.patch
source = fix-atom-sh.patch
diff --git a/PKGBUILD b/PKGBUILD
index 20954cd4f961..f829914ba11f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@
# Contributor: Nicola Squartini <tensor5@gmail.com>
pkgname=atom-transparent
-pkgver=1.46.0
-_commit=c1fea480e3f4f9c615e23c7da221deb9d3196005
-
+pkgver=1.48.0
+_commit=5df9cd3d774352321ffeb65570de77906792f8bc
pkgrel=1
pkgdesc='A hackable text editor for the 21st Century, with transparency patch'
arch=('x86_64')
url='https://github.com/atom/atom'
license=('MIT' 'custom')
-depends=('apm' 'electron4' 'libxkbfile' 'ripgrep')
+depends=('apm' 'electron5' 'libxkbfile' 'ripgrep')
makedepends=('git' 'npm')
optdepends=('ctags: symbol indexing support'
'git: Git and GitHub integration')
conflicts=('atom')
provides=('atom')
+replaces=('atom-editor')
options=(!emptydirs)
source=("git+https://github.com/atom/atom.git#commit=${_commit}"
'atom.js'
@@ -55,7 +55,7 @@ prepare() {
patch -Np1 -i ../fix-restart.patch
patch -Np1 -i ../node-env-production.patch
patch -Np1 -i ../no-unsafe-eval-warning.patch
- patch -Np1 -i "${srcdir}"/enable-transparency.patch
+ patch -Np1 -i ../enable-transparency.patch
}
build() {
@@ -63,7 +63,7 @@ build() {
ATOM_RESOURCE_PATH="${PWD}" \
npm_config_build_from_source=true \
- npm_config_target=$(< /usr/lib/electron4/version) \
+ npm_config_target=$(< /usr/lib/electron5/version) \
apm install
# Use system ctags
@@ -85,22 +85,18 @@ build() {
env \
npm_config_disturl=https://electronjs.org/headers \
npm_config_runtime=electron \
- npm_config_target=$(< /usr/lib/electron4/version) \
+ npm_config_target=$(< /usr/lib/electron5/version) \
node-gyp rebuild
cd ../..
cd script
- # Hack to avoid using Node 12
- env \
- npm_config_disturl=https://electronjs.org/headers \
- npm_config_runtime=electron \
- npm_config_target=$(< /usr/lib/electron4/version) \
- npm install
+ npm install
+ # Hack to avoid using Node > 12 (https://github.com/babel/babel/issues/11216)
# Set ELECTRON_VERSION (see use-system-electron.patch)
env \
ELECTRON_RUN_AS_NODE=1 \
- ELECTRON_VERSION=$(< /usr/lib/electron4/version) \
- electron4 \
+ ELECTRON_VERSION=$(< /usr/lib/electron5/version) \
+ electron5 \
build --no-bootstrap
}