summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoki Kanazawa2017-09-12 23:58:54 +0900
committerNaoki Kanazawa2017-09-12 23:58:54 +0900
commit44a2d35c033efb4dbb56e2100ed9a7bc3d1b1eb1 (patch)
treefc8916601e00b57d6a6c8eef764c06106272634b
downloadaur-44a2d35c033efb4dbb56e2100ed9a7bc3d1b1eb1.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
-rw-r--r--atomic-tweetdeck.desktop10
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81c8d6ca394e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Sep 12 14:54:39 UTC 2017
+pkgbase = atomic-tweetdeck
+ pkgdesc = Just a small Electron TweetDeck app.
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = https://github.com/dogancelik/atomic-tweetdeck
+ arch = any
+ license = MIT
+ depends = gtk2
+ depends = gconf
+ depends = xdg-utils
+ depends = libxtst
+ depends = libxss
+ depends = nss
+ depends = alsa-lib
+ source = https://github.com/dogancelik/atomic-tweetdeck/releases/download/v0.10.1/atomic-tweetdeck-linux-x64.tgz
+ source = atomic-tweetdeck.desktop
+ md5sums = 8168e23175084ac7f5a0fb33c213ff6b
+ md5sums = 6d0350843795b0e996d159e5dd6607bf
+
+pkgname = atomic-tweetdeck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f27c042c3d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Naoki Kanazawa <nk dot naoki912 at gmail dot com>
+pkgname=atomic-tweetdeck
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="Just a small Electron TweetDeck app."
+arch=('any')
+url="https://github.com/dogancelik/atomic-tweetdeck"
+license=('MIT')
+depends=('gtk2' 'gconf' 'xdg-utils' 'libxtst' 'libxss' 'nss' 'alsa-lib')
+source=(
+ "${url}/releases/download/v${pkgver}/atomic-tweetdeck-linux-x64.tgz"
+ "atomic-tweetdeck.desktop"
+)
+md5sums=(
+ '8168e23175084ac7f5a0fb33c213ff6b'
+ '6d0350843795b0e996d159e5dd6607bf'
+)
+
+package() {
+ install -dm755 ${pkgdir}/usr/bin
+ install -dm755 ${pkgdir}/usr/lib
+
+ cp -a ${srcdir} ${pkgdir}/usr/lib/${pkgname}
+
+ ln -s /usr/lib/atomic-tweetdeck/atomic-tweetdeck ${pkgdir}/usr/bin/atomic-tweetdeck
+
+ install -Dm644 atomic-tweetdeck.desktop ${pkgdir}/usr/share/applications/atomic-tweetdeck.desktop
+
+ unlink ${pkgdir}/usr/lib/${pkgname}/atomic-tweetdeck-linux-x64.tgz
+ unlink ${pkgdir}/usr/lib/${pkgname}/atomic-tweetdeck.desktop
+}
diff --git a/atomic-tweetdeck.desktop b/atomic-tweetdeck.desktop
new file mode 100644
index 000000000000..9336c0031fa0
--- /dev/null
+++ b/atomic-tweetdeck.desktop
@@ -0,0 +1,10 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Name=atomic-tweetdeck
+Categories=Network;
+Comment=just a small Electron TweetDeck app.
+Exec=/usr/bin/atomic-tweetdeck
+GenericName=Twitter Client
+Icon=atomic-tweetdeck
+StartupNotify=false
+Type=Application