summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 23:58:05 +0200
committersmls2015-07-09 23:58:05 +0200
commit09f91f80ee71af92d0fa1c57586e241a8c46269a (patch)
tree8bea8c318f0966b2288074b84540bb635de8c403
parentbb9a470ec496022f8a362e4be8fb418e1f02f963 (diff)
downloadaur-09f91f80ee71af92d0fa1c57586e241a8c46269a.tar.gz
Better version string, and all around clean-up
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD61
-rw-r--r--atomzombiesmasher.desktop13
3 files changed, 44 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7f4e31a36d0..e328c9611c4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = atomzombiesmasher-hib
- pkgdesc = RTS, evacuating civilians out of zombie-contaminated cities. (Commercial)
- pkgver = 1.953
+ pkgdesc = A 2D tactics/strategy game where you evacuate civilians from zombie-infested cities. (Humble Bundle/Store version)
+ pkgver = 1.953+h20130409
pkgrel = 1
url = http://blendogames.com/atomzombiesmasher/
arch = any
@@ -11,7 +11,7 @@ pkgbase = atomzombiesmasher-hib
source = atomzombiesmasher.desktop
source = https://apps.ubuntu.com/site_media/icons/2013/12/atom-zombie-smashertCCn9V.png
md5sums = 6902c845a21e92c62f5b33b38715c797
- md5sums = 73ed32320ac1dc645754a6520b4e4e8b
+ md5sums = b1f2e18834d1bec5785a889f642e2191
md5sums = 341ce551a8525be96d6c59c1bf9efd2a
pkgname = atomzombiesmasher-hib
diff --git a/PKGBUILD b/PKGBUILD
index ba078c2b98d0..6830cb339ca3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,53 @@
-# Maintainer: Capi Etheriel <barraponto AT gmail DOT com>
+# Maintainer: Sam S. <smls75@gmail.com>
+# Contributor: Capi Etheriel <barraponto AT gmail DOT com>
# Based on work by Malte Wessel <muunleit AT lavabit DOT com>
pkgname=atomzombiesmasher-hib
-_pkgname=atomzombiesmasher
-pkgver=1.953
+pkgver=1.953+h20130409
+_hibver=v1_953-er
pkgrel=1
-pkgdesc="RTS, evacuating civilians out of zombie-contaminated cities. (Commercial)"
+pkgdesc="A 2D tactics/strategy game where you evacuate civilians from zombie-infested cities. (Humble Bundle/Store version)"
arch=('any')
url="http://blendogames.com/atomzombiesmasher/"
license=("custom:commercial")
-[ "$CARCH" = "x86_64" ] && depends=('libgdiplus' 'mono' 'csfml-bin')
+depends_x86_64=('libgdiplus' 'mono' 'csfml-bin')
conflicts=("atomzombiesmasherdemo" "atomzombiesmasher")
-_gamepkg="${_pkgname}_v${pkgver//./_}-er.tar.gz"
+
+_gamepkg="atomzombiesmasher_$_hibver.tar.gz"
source=("$_gamepkg::hib://$_gamepkg"
"atomzombiesmasher.desktop"
"https://apps.ubuntu.com/site_media/icons/2013/12/atom-zombie-smashertCCn9V.png")
md5sums=("6902c845a21e92c62f5b33b38715c797"
- "73ed32320ac1dc645754a6520b4e4e8b"
+ "b1f2e18834d1bec5785a889f642e2191"
"341ce551a8525be96d6c59c1bf9efd2a")
-build() {
- # rely on realpath to get the actual directory
- sed -i 's|`dirname $0`/game|"$(dirname $(realpath $0))"/game|' $srcdir/$_pkgname/AtomZombieSmasher
- # arch command has been deprecated upstream
- sed -i 's/arch/uname -m/' $srcdir/$_pkgname/AtomZombieSmasher
+_installname=atomzombiesmasher
+[ $CARCH == "i686" ] && _arch=x86 || _arch=x86_64
+
+prepare() {
+ echo -e "#!/usr/bin/sh\n" \
+ "export MONO_WINFORMS_XIM_STYLE=disabled\n" \
+ "cd /opt/$_installname/game\n" \
+ "./AtomZombieSmasher.bin.$_arch" '"$@"' \
+ > "launcher.sh"
+ mv $_installname/readme.html .
}
package() {
- # Create pkgdir folders
- install -d $pkgdir/usr/bin
- install -d $pkgdir/usr/share/doc/$_pkgname
- install -d $pkgdir/usr/share/applications
- install -g games -d $pkgdir/opt/$_pkgname
-
- # Copy game
- cp -a $srcdir/$_pkgname/* $pkgdir/opt/$_pkgname
- mv $pkgdir/opt/$_pkgname/readme.html $pkgdir/usr/share/doc/$_pkgname
- cp -a $srcdir/$_pkgname.desktop $pkgdir/usr/share/applications/
-
- # Copy game icon
- mv $srcdir/atom-zombie-smashertCCn9V.png $pkgdir/opt/$_pkgname/game/$_pkgname.png
+ # Game data
+ install -g games -d $pkgdir/opt/$_installname
+ cp -rT $_installname "$pkgdir"/opt/$_installname
+
+ # Readme
+ install -D readme.html \
+ "$pkgdir"/usr/share/doc/$_installname/readme.html
+
+ # Desktop entry
+ install -D $_installname.desktop \
+ "$pkgdir"/usr/share/applications/$_installname.desktop
+ install -D atom-zombie-smashertCCn9V.png \
+ "$pkgdir"/usr/share/pixmaps/$_installname.png
- # Link executable
- ln -s /opt/$_pkgname/AtomZombieSmasher $pkgdir/usr/bin/$_pkgname
+ # Launcher
+ install -Dm755 launcher.sh "$pkgdir"/usr/bin/$_installname
}
diff --git a/atomzombiesmasher.desktop b/atomzombiesmasher.desktop
index dba1c370bc94..79bfd16a701a 100644
--- a/atomzombiesmasher.desktop
+++ b/atomzombiesmasher.desktop
@@ -1,9 +1,10 @@
[Desktop Entry]
-Name=AtomZombieSmasher
-GenericName=AtomZombieSmasher
-Comment=RTS, evacuating civilians out of zombie-contaminated cities
-Exec=atomzombiesmasher
-Icon=/opt/atomzombiesmasher/game/atomzombiesmasher.png
-Terminal=false
+Value=1.0
Type=Application
Categories=Game;
+Name=Atom Zombie Smasher
+Comment=Blendo Games
+GenericName=Real-time Tactics Game
+Icon=atomzombiesmasher
+Exec=atomzombiesmasher
+Terminal=false