summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-28 19:58:19 +0200
committersmls2015-07-28 19:58:19 +0200
commitc630878d41fb44f3f5c0ffd39a3e6a2c3a45025f (patch)
tree7b809cb9c7e8c8619403818485068aed5783919b
parent3930d46978e0ed0b8bc303acb69d4860d1b9ec7d (diff)
downloadaur-c630878d41fb44f3f5c0ffd39a3e6a2c3a45025f.tar.gz
Remove bundled mono; use system-wide one instead
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD37
2 files changed, 26 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 357c3305dc55..f81faa43690d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = atomzombiesmasher-hib
pkgdesc = A 2D tactics/strategy game where you evacuate civilians from zombie-infested cities. (Humble Bundle/Store version)
pkgver = 1.953+h20130409
- pkgrel = 1
+ pkgrel = 2
url = http://blendogames.com/atomzombiesmasher/
arch = any
license = custom:commercial
+ depends = mono
+ depends = libgdiplus
+ depends = csfml-bin
depends = openal
depends = flac
depends = libpng12
depends = libjpeg6
depends = libtiff3
- depends = libgdiplus
- depends = csfml-bin
+ depends = xdg-utils
conflicts = atomzombiesmasherdemo
conflicts = atomzombiesmasher
+ conflicts = atomzombiesmasher-demo
+ replaces = atomzombiesmasher
source = atomzombiesmasher_v1_953-er.tar.gz::hib://atomzombiesmasher_v1_953-er.tar.gz
source = atomzombiesmasher.desktop
source = https://apps.ubuntu.com/site_media/icons/2013/12/atom-zombie-smashertCCn9V.png
diff --git a/PKGBUILD b/PKGBUILD
index 07828c57d17c..7daebb144aff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgname=atomzombiesmasher-hib
pkgver=1.953+h20130409
_hibver=v1_953-er
-pkgrel=1
+pkgrel=2
pkgdesc="A 2D tactics/strategy game where you evacuate civilians from zombie-infested cities. (Humble Bundle/Store version)"
arch=('any')
url="http://blendogames.com/atomzombiesmasher/"
license=("custom:commercial")
-depends=('openal' 'flac' 'libpng12' 'libjpeg6' 'libtiff3'
- 'libgdiplus' 'csfml-bin')
-conflicts=("atomzombiesmasherdemo" "atomzombiesmasher")
+depends=('mono' 'libgdiplus' 'csfml-bin' 'openal' 'flac' 'libpng12' 'libjpeg6' 'libtiff3' 'xdg-utils')
+conflicts=("atomzombiesmasherdemo" "atomzombiesmasher" "atomzombiesmasher-demo")
+replaces=("atomzombiesmasher")
PKGEXT='.pkg.tar'
_gamepkg="atomzombiesmasher_$_hibver.tar.gz"
@@ -25,31 +25,31 @@ md5sums=("6902c845a21e92c62f5b33b38715c797"
_installname=atomzombiesmasher
case $CARCH in
- i686) _arch=x86; _other=x86_64; _lib=lib; _libother=lib64 ;;
- x86_64) _arch=x86_64; _other=x86; _lib=lib64; _libother=lib ;;
+ i686) _lib=lib; _libother=lib64 ;;
+ x86_64) _lib=lib64; _libother=lib ;;
esac
prepare() {
- # Create custom launcher
+ cd atomzombiesmasher
+
+ msg2 "Prepare launch script..."
echo -e "#!/usr/bin/sh\n" \
"export MONO_WINFORMS_XIM_STYLE=disabled\n" \
"cd /opt/$_installname\n" \
- "exec ./AtomZombieSmasher.bin.$_arch" '"$@"' \
- > "launcher.sh"
-
- cd $_installname
+ "exec mono AtomZombieSmasher.exe" '"$@"' \
+ > game/$_installname
- # Fix permissions
+ msg2 "Fix permissions..."
find -type f -exec chmod 644 {} \;
- chmod +x game/AtomZombieSmasher.bin*
+ chmod 755 game/$_installname
- # Remove unneeded files
- rm game/AtomZombieSmasher.bin.$_other
+ msg2 "Remove unneeded files..."
+ rm game/AtomZombieSmasher.bin.*
rm -r game/$_libother
- ls game/$_lib/
- rm -r game/$_lib/{libcsfml*,libsfml*}
+ rm -r game/$_lib/{libmono*,libMono*,libcsfml*,libsfml*}
rm -r game/$_lib/{libopenal.so.1,libFLAC.so.8,libgdiplus.so}
rm -r game/$_lib/{libjpeg.so.62,libpng12.so.0,libtiff.so.3}
+ rm -r game/{mono,{Accessibility,Mono*,mscorlib,System*}.dll}
# Set apart files to install separately
mv readme.html "$srcdir"
@@ -71,5 +71,6 @@ package() {
"$pkgdir"/usr/share/pixmaps/$_installname.png
# Launcher
- install -Dm755 launcher.sh "$pkgdir"/usr/bin/$_installname
+ install -d "$pkgdir"/usr/bin
+ ln -s /opt/$_installname/$_installname "$pkgdir"/usr/bin/$_installname
}