summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfossdd2024-04-06 15:25:33 +0200
committerfossdd2024-04-06 15:25:33 +0200
commit240387b9f95991095386d677c618c7f2ca527e05 (patch)
tree83e3336f5747ddb37eda38ec352c0b2a03c573bd
downloadaur-240387b9f95991095386d677c618c7f2ca527e05.tar.gz
upgpkg: atools 20.2.2-1
upstream release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bda7a28eb7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = atools
+ pkgdesc = Auxilary scripts for abuild
+ pkgver = 20.2.2
+ pkgrel = 1
+ url = https://gitlab.alpinelinux.org/Leo/atools
+ arch = x86_64
+ arch = aarch64
+ arch = armv7
+ arch = x86
+ arch = ppc64le
+ arch = s390x
+ license = MIT
+ checkdepends = bats
+ makedepends = scdoc
+ makedepends = redo
+ makedepends = go
+ depends = lua53
+ depends = busybox
+ source = atools-20.2.2.tar.gz::https://gitlab.alpinelinux.org/Leo/atools/-/archive/20.2.2/atools-20.2.2.tar.gz
+ sha512sums = 63c95e4b86d99bd913fafe56c89dddd52e11d7bd84e138d236043133b0a7103a9de7393265c5ad387a61218c1f79a458460dca213ff0e9e9a4a65be9313e6580
+
+pkgname = atools
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c65750b8544
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: fossdd <fossdd@pwned.life>
+pkgname=atools
+pkgver=20.2.2
+pkgrel=1
+pkgdesc="Auxilary scripts for abuild"
+url="https://gitlab.alpinelinux.org/Leo/atools"
+arch=("x86_64" "aarch64" "armv7" "x86" "ppc64le" "s390x")
+license=("MIT")
+depends=("lua53" "busybox")
+makedepends=("scdoc" "redo" "go")
+checkdepends=("bats")
+source=("$pkgname-$pkgver.tar.gz::https://gitlab.alpinelinux.org/Leo/atools/-/archive/$pkgver/atools-$pkgver.tar.gz")
+
+prepare() {
+ find -type f | while read file; do
+ sed -E -i "$file" \
+ -e '1s|#!/usr/bin/env ash$|#!/bin/busybox ash|'
+ done
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ redo build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ redo check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" redo install
+}
+
+sha512sums=('63c95e4b86d99bd913fafe56c89dddd52e11d7bd84e138d236043133b0a7103a9de7393265c5ad387a61218c1f79a458460dca213ff0e9e9a4a65be9313e6580')