summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Laws2015-06-26 09:28:17 +0900
committerMark Laws2015-06-26 09:31:18 +0900
commitf1396578e1b4b87acbf27fe23a89d5390462564f (patch)
treeceeebb69b8e68e48b77e2d5bbf4da2d02017dbf5
downloadaur-f1396578e1b4b87acbf27fe23a89d5390462564f.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c68f46b4d951
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ats2-contrib
+ pkgdesc = Extra libraries for the ATS2 programming language
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://www.ats-lang.org/
+ arch = any
+ license = GPL3
+ depends = ats2-postiats
+ options = staticlibs
+ source = http://downloads.sourceforge.net/project/ats2-lang/ats2-lang/ats2-postiats-0.2.0/ATS2-Postiats-contrib-0.2.0.tgz
+ sha256sums = e2ce0d62684e06be4c23aa889cae7ea45447c36f7cdc6c3ee173e9586426ffa1
+
+pkgname = ats2-contrib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81542763d78e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mark Laws <eMm Dee eLl at 60 hz dot org>
+# Contributor: Ben Darwin <bcdarwin@gmail.com>
+
+pkgname=ats2-contrib
+_pkgname=ATS2-Postiats-contrib
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Extra libraries for the ATS2 programming language"
+arch=('any')
+url="http://www.ats-lang.org/"
+license=('GPL3')
+depends=('ats2-postiats')
+options=('staticlibs')
+source=(
+ "http://downloads.sourceforge.net/project/ats2-lang/ats2-lang/ats2-postiats-${pkgver}/$_pkgname-$pkgver.tgz")
+sha256sums=('e2ce0d62684e06be4c23aa889cae7ea45447c36f7cdc6c3ee173e9586426ffa1')
+
+package() {
+ local ats2init=/etc/profile.d/ats2-postiats
+ source "${ats2init}.sh"
+
+ mkdir -p "$pkgdir/$PATSHOME"
+ mv "$_pkgname-$pkgver"/* "$pkgdir/$PATSHOME"
+
+ local profiled="$pkgdir/etc/profile.d"
+ mkdir -p "$profiled"
+ local scriptbase="${profiled}/${pkgname}"
+ echo "source ${ats2init}.sh" > "${scriptbase}.sh"
+ echo 'export PATSHOMERELOC=$PATSHOME' >> "${scriptbase}.sh"
+ echo "source ${ats2init}.csh" > "${scriptbase}.csh"
+ echo 'setenv PATSHOMERELOC $PATSHOME' >> "${scriptbase}.csh"
+
+ chmod 0755 "${scriptbase}.sh" "${scriptbase}.csh"
+}