summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Rodas2015-06-25 00:32:41 -0500
committerMario Rodas2015-06-25 00:32:41 -0500
commit4e3d3b4a1a8b9148b690922ccbe26be4923d52de (patch)
tree3d563e203ecf02a5921df2239e6c1e5c13e53aae
downloadaur-4e3d3b4a1a8b9148b690922ccbe26be4923d52de.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac8c262a1c9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ats2-postiats
+ pkgdesc = Statically typed programming language
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://www.ats-lang.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = bash
+ depends = gmp
+ optdepends = gmp
+ options = staticlibs
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/project/ats2-lang/ats2-lang/ats2-postiats-0.2.0/ATS2-Postiats-0.2.0.tgz
+ sha256sums = 455e269f5d56f0f92f8aa83d47e8e221135d1fe57f03f4afd9d1a07ab1ad3dfe
+
+pkgname = ats2-postiats
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c28da952c975
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mario Rodas <marsam@users.noreply.github.com>
+
+pkgname=ats2-postiats
+_pkgname=ATS2-Postiats
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Statically typed programming language"
+arch=('i686' 'x86_64')
+url="http://www.ats-lang.org/"
+license=('GPL3')
+depends=('bash' 'gmp')
+optdepends=('gmp')
+options=('staticlibs' '!emptydirs')
+source=("http://downloads.sourceforge.net/project/ats2-lang/ats2-lang/ats2-postiats-${pkgver}/${_pkgname}-${pkgver}.tgz")
+sha256sums=('455e269f5d56f0f92f8aa83d47e8e221135d1fe57f03f4afd9d1a07ab1ad3dfe')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make all
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ local profiled="${pkgdir}/etc/profile.d"
+ local patshome="/usr/lib/${pkgname}-${pkgver}"
+ mkdir -p "${profiled}"
+
+ echo "export PATSHOME=${patshome}" > "${profiled}/${pkgname}.sh"
+ echo "setenv PATSHOME ${patshome}" > "${profiled}/${pkgname}.csh"
+
+ chmod 0755 "${profiled}/${pkgname}.sh" "${profiled}/${pkgname}.csh"
+}
+
+# Local Variables:
+# compile-command: "makepkg -sm"
+# End: