summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreno Cunha Queiroz2021-03-26 00:08:45 -0300
committerBreno Cunha Queiroz2021-03-26 00:08:45 -0300
commitead6533adc8db0bdcc56f47233e9fca7a9d467c6 (patch)
tree4170d14b666539977e9d89c0d09d6aba3627edd0
parent172c8294ce66b2659646a867cc6a84f811a9f7d3 (diff)
downloadaur-atta.tar.gz
Test: 0.0.1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD61
2 files changed, 31 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8040e122c6e0..7102c0f631dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = atta
- pkgdesc = Robot simulator for 2D and 3D applications made with Vulkan API (optional Ray Tracing) (early stages)
- pkgver = 0.0.1.r.
- pkgrel = 1
+ pkgdesc = High-performance simulator for multi-robot systems (early stages)
+ pkgver = 0.0.1.1
+ pkgrel = 2
url = https://github.com/Brenocq/Atta.git
arch = x86_64
arch = i686
license = MIT
makedepends = git
- source = git+https://github.com/Brenocq/Atta.git
+ depends = glfw
+ depends = freetype2
+ depends = vulkan-headers
+ provides = atta
+ source = atta::git://github.com/Brenocq/Atta.git
md5sums = SKIP
pkgname = atta
diff --git a/PKGBUILD b/PKGBUILD
index 644435838d2f..be247d011137 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,41 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: Breno Cunha Queiroz <admin@brenocq.com>
pkgname=atta
-pkgver=0.0.1.r.
-pkgrel=1
-epoch=
-pkgdesc="Robot simulator for 2D and 3D applications made with Vulkan API (optional Ray Tracing) (early stages)"
+pkgver=0.0.1.1
+pkgrel=2
+pkgdesc="High-performance simulator for multi-robot systems (early stages)"
arch=(x86_64 i686)
url="https://github.com/Brenocq/Atta.git"
license=('MIT')
-groups=()
-depends=()
-makedepends=(git)
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("git+$url")
-noextract=()
+depends=('glfw' 'freetype2' 'vulkan-headers')
+makedepends=('git')
+provides=('atta')
+source=("$pkgname::git://github.com/Brenocq/Atta.git")
md5sums=('SKIP')
-validpgpkeys=()
#prepare() {
# cd "$pkgname-$pkgver"
# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
#}
-pkgver() {
- cd "${_pkgname}"
- printf "0.0.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+#pkgver() {
+# cd $pkgname
+# printf 0.0.1.1
+# # TODO get version from github last tag
+# #printf "0.0.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+#}
build() {
- echo "----- Build ----- "
- cd Atta
- pwd
- #./configure --prefix=/usr
- #make
-}
-
-check() {
- echo "----- Check ----- "
+ cd $pkgname
+ mkdir -p build
+ cd build
+ cmake -D CMAKE_BUILD_TYPE=Release -D CMAKE_INSTALL_PREFIX=../../../pkg/atta/usr -D ATTA_GENERATE_PACKAGE_INSTALL=1 ..
+ make -j
}
package() {
- echo "----- Package section ----- "
+ cd $pkgname/build
+ make install
+ install -Dm755 ./atta $pkgdir/usr/bin/atta
+ install -d $pkgdir/usr/include/
+ install -d $pkgdir/usr/lib/
}