summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreno Cunha Queiroz2021-02-04 20:58:06 -0300
committerBreno Cunha Queiroz2021-02-04 20:58:06 -0300
commit96825457d32122845e7d393de08f314c52a48278 (patch)
treeaaa47f88aa2ed6c77792ae645466b2fda8aa18d5
downloadaur-96825457d32122845e7d393de08f314c52a48278.tar.gz
Core: First push
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD56
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1a5d08b8f80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = atta-git
+ pkgdesc = Robot simulator for 2D and 3D applications made with Vulkan API (optional Ray Tracing) (early stages)
+ pkgver = 0.0.1.r13.14f4be7
+ pkgrel = 1
+ url = https://github.com/Brenocq/Atta.git
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ source = git+https://github.com/Brenocq/Atta.git
+ md5sums = SKIP
+
+pkgname = atta-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74895234216a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Breno Cunha Queiroz <admin@brenocq.com>
+pkgname=atta-git
+pkgver=0.0.1.r13.14f4be7
+pkgrel=1
+epoch=
+pkgdesc="Robot simulator for 2D and 3D applications made with Vulkan API (optional Ray Tracing) (early stages)"
+arch=(x86_64 i686)
+url="https://github.com/Brenocq/Atta.git"
+license=('MIT')
+groups=()
+depends=()
+makedepends=(git)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+#prepare() {
+# cd "$pkgname-$pkgver"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+#}
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "0.0.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ echo "----- Build ----- "
+ cd Atta
+ pwd
+ #./configure --prefix=/usr
+ #make
+}
+
+check() {
+ echo "----- Check ----- "
+}
+
+package() {
+ echo "----- Package section ----- "
+}