summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzan2020-07-17 22:45:07 -0400
committerzan2020-07-17 22:45:07 -0400
commitc383820d527cf1cf1b9e9a9e344a4921f46a2263 (patch)
treee91f412175cdca0757595eee3589bd46682d1792
parentf6861417ae7f617bbd85c447cc43af027477c991 (diff)
downloadaur-c383820d527cf1cf1b9e9a9e344a4921f46a2263.tar.gz
invent.kde migration
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD38
2 files changed, 20 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d064f20c8a72..efd76f0cf060 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = attica-git
pkgdesc = Qt5 library that implements the Open Collaboration Services API
- pkgver = v5.68.0.rc1.r0.g5a49f34
+ pkgver = v5.72.0.r2.gef33d1e
pkgrel = 1
url = https://projects.kde.org/projects/frameworks/attica
- arch = i686
arch = x86_64
+ groups = kf5
license = LGPL
- makedepends = cmake
makedepends = git
- makedepends = extra-cmake-modules-git
+ makedepends = extra-cmake-modules
depends = qt5-base
provides = attica
conflicts = attica
- source = attica::git+git://anongit.kde.org/attica
+ source = git+https://invent.kde.org/frameworks/attica.git
md5sums = SKIP
pkgname = attica-git
diff --git a/PKGBUILD b/PKGBUILD
index 0f465bf48ad7..be60e5885f5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,33 @@
+# Maintainer: zan <zan@420blaze.it>
+
pkgname=attica-git
-pkgver=v5.68.0.rc1.r0.g5a49f34
+_name=${pkgname%-git}
+pkgver=v5.72.0.r2.gef33d1e
pkgrel=1
pkgdesc='Qt5 library that implements the Open Collaboration Services API'
-arch=('i686' 'x86_64')
+arch=(x86_64)
url='https://projects.kde.org/projects/frameworks/attica'
-license=('LGPL')
-depends=('qt5-base')
-makedepends=('cmake' 'git' 'extra-cmake-modules-git')
-conflicts=('attica')
-provides=('attica')
-source=('attica::git+git://anongit.kde.org/attica')
+license=(LGPL)
+depends=(qt5-base)
+makedepends=(git extra-cmake-modules)
+groups=(kf5)
+conflicts=(attica)
+provides=(attica)
+source=("git+https://invent.kde.org/frameworks/$_name.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/attica"
+ cd $_name
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- mkdir -p "${srcdir}/build"
-}
-
build() {
- cd "${srcdir}/build"
- cmake "${srcdir}/attica" -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_INSTALL_DIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
- -DBUILD_TESTING=OFF
- make
+ cmake -B build -S $_name
+ cmake --build build
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}