summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-22 00:33:59 +0800
committerChocobo12017-08-22 00:39:13 +0800
commite675fd36a168f2c5d137540365f993e8e047389e (patch)
tree58139f0148b8432bee1ab541854e02297390164f
downloadaur-e675fd36a168f2c5d137540365f993e8e047389e.tar.gz
newpkg: attr-git 2.4.47.r49.gc1a7b53-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e4b37843161
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = attr-git
+ pkgdesc = Provides useful functions commonly found on BSD systems
+ pkgver = 2.4.47.r49.gc1a7b53
+ pkgrel = 1
+ url = https://savannah.nongnu.org/projects/attr
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = git
+ makedepends = gettext
+ depends = glibc
+ provides = xfsattr
+ conflicts = xfsattr
+ replaces = xfsattr
+ options = staticlibs
+ source = git+https://git.savannah.gnu.org/git/attr.git
+ sha256sums = SKIP
+
+pkgname = attr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2279d4b6b667
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=attr-git
+pkgver=2.4.47.r49.gc1a7b53
+pkgrel=1
+pkgdesc="Provides useful functions commonly found on BSD systems"
+arch=('i686' 'x86_64')
+url="https://savannah.nongnu.org/projects/attr"
+license=('GPL' 'LGPL')
+depends=('glibc')
+makedepends=('git' 'gettext')
+provides=('xfsattr')
+conflicts=('xfsattr')
+replaces=('xfsattr')
+options=('staticlibs')
+source=("git+https://git.savannah.gnu.org/git/attr.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "attr"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "attr"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "attr"
+
+ #make check
+}
+
+package() {
+ cd "attr"
+
+ make DESTDIR="$pkgdir" install
+}