summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeffrey Clark2016-02-20 22:35:00 -0600
committerJeffrey Clark2016-02-20 22:35:00 -0600
commit4640aef1228a7dae274640aac20dc2327c6ae3e8 (patch)
tree0ea11c585c2d08b7bba3a7378690a9f8145d60a8
parente42dc55c386ecd13872e8a210b49ea9e07331c2e (diff)
downloadaur-4640aef1228a7dae274640aac20dc2327c6ae3e8.tar.gz
remove abbr object from pkgver, add makedepend
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b424adc184a3..c786e17aff3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Fri Feb 12 03:24:37 UTC 2016
+# Sun Feb 21 04:33:14 UTC 2016
pkgbase = attract-git
pkgdesc = A graphical front-end for command line emulators that hides the underlying operating system and is intended to be controlled with a joystick or gamepad.
- pkgver = 1.6.2.49.6c3b9fc
+ pkgver = 2.0.0.rc1.r2
pkgrel = 1
url = http://www.attractmode.org/
install = attract.install
arch = i686
arch = x86_64
license = GPL3
+ makedepends = git
depends = sfml
depends = openal
depends = ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index 21f7841888fc..12722635b378 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
_gitname=attract
_gitbranch=master
pkgname=${_gitname}-git
-pkgver=1.6.2.49.6c3b9fc
+pkgver=2.0.0.rc1.r2
pkgrel=1
pkgdesc="A graphical front-end for command line emulators that hides the underlying operating system and is intended to be controlled with a joystick or gamepad."
arch=('i686' 'x86_64')
url="http://www.attractmode.org/"
license=('GPL3')
depends=('sfml' 'openal' 'ffmpeg' 'fontconfig' 'libxinerama' 'libarchive')
+makedepends=('git')
conflicts=('attract')
provides=('attract')
replaces=('attractmode-git')
@@ -25,7 +26,8 @@ sha1sums=('SKIP'
pkgver() {
cd "${_gitname}"
- printf "%s" "$(git describe --long --tags | sed 's/v//g;s/\([^-]*-\)g/\1/;s/-/./g')"
+ tag=$(git describe --abbrev=0)
+ printf "%s.r%s\n" "$(echo ${tag} | sed 's/^v//;s/-/./g')" "$(git rev-list --count ${tag}..HEAD)"
}
build() {