summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeffrey Clark2016-02-09 21:32:04 -0600
committerJeffrey Clark2016-02-09 21:34:26 -0600
commit4f0154de596d6e295138c844259fa25153c7e622 (patch)
tree47be92e81c26e20e3b7a7bbbbc80f05edeed6a54
downloadaur-4f0154de596d6e295138c844259fa25153c7e622.tar.gz
Initial version
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD43
-rw-r--r--attract.desktop9
-rw-r--r--attract.install13
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a6c95ebfc50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Wed Feb 10 03:24:04 UTC 2016
+pkgbase = attract-git
+ pkgdesc = A graphical front-end for command line emulators that hides the underlying operating system and is intended to be controlled with a joystick or gamepad.
+ pkgver = 1.6.2.47
+ pkgrel = 1
+ url = http://www.attractmode.org/
+ install = attract.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = sfml
+ depends = openal
+ depends = ffmpeg
+ depends = fontconfig
+ depends = libxinerama
+ depends = libarchive
+ conflicts = attract
+ replaces = attractmode-git
+ source = attract::git+https://github.com/mickelson/attract.git#branch=master
+ source = https://github.com/mickelson/attract/releases/download/v1.6.2/ATTRACT.MODE.intro.16-9.v6.1080p.mp4
+ source = attract.desktop
+ source = attract.install
+ sha1sums = SKIP
+ sha1sums = 37885c5f2e6194e689c36eb88c43bd5bb23363d0
+ sha1sums = cf599edbff2962b5ff0a77560a95d80cec828264
+ sha1sums = 284afdf55086f2a626d5ab617240ff74cea30f53
+
+pkgname = attract-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af50ca2c3b7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Jeffrey Clark (h0tw1r3) <dude@zaplabs.com>
+
+_gitname=attract
+_gitbranch=master
+pkgname=${_gitname}-git
+pkgver=1.6.2.47
+pkgrel=1
+pkgdesc="A graphical front-end for command line emulators that hides the underlying operating system and is intended to be controlled with a joystick or gamepad."
+arch=('i686' 'x86_64')
+url="http://www.attractmode.org/"
+license=('GPL3')
+depends=('sfml' 'openal' 'ffmpeg' 'fontconfig' 'libxinerama' 'libarchive')
+conflicts=('attract')
+provides=('attract')
+replaces=('attractmode-git')
+install="${_gitname}.install"
+source=("${_gitname}::git+https://github.com/mickelson/${_gitname}.git#branch=${_gitbranch}"
+ "https://github.com/mickelson/${pkgname%-*}/releases/download/v1.6.2/ATTRACT.MODE.intro.16-9.v6.1080p.mp4"
+ "${_gitname}.desktop"
+ "${install}")
+sha1sums=('SKIP'
+ '37885c5f2e6194e689c36eb88c43bd5bb23363d0'
+ 'cf599edbff2962b5ff0a77560a95d80cec828264'
+ '284afdf55086f2a626d5ab617240ff74cea30f53')
+
+pkgver() {
+ cd "${_gitname}"
+ tag=$(git describe --tags --abbrev=0)
+ printf "%s.%s" ${tag//v} $(git rev-list --count ${tag}..HEAD)
+}
+
+build() {
+ cd "${_gitname}"
+ make prefix=/usr
+}
+
+package() {
+ cd "${_gitname}"
+ make prefix="${pkgdir}/usr" install
+ install -Dm644 ../ATTRACT.MODE.intro.16-9.v6.1080p.mp4 ${pkgdir}/usr/share/attract/intro/intro.mp4
+ install -Dm644 util/icon.png ${pkgdir}/usr/share/pixmaps/attract.png
+ install -Dm644 ${srcdir}/attract.desktop ${pkgdir}/usr/share/applications/attract.desktop
+}
diff --git a/attract.desktop b/attract.desktop
new file mode 100644
index 000000000000..b883873ce199
--- /dev/null
+++ b/attract.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Attract-Mode
+Comment=Front-end for command line emulators
+Exec=attract
+Icon=attract
+Terminal=false
+Type=Application
+StartupNotify=false
+Categories=Game;
diff --git a/attract.install b/attract.install
new file mode 100644
index 000000000000..841d8012a3b2
--- /dev/null
+++ b/attract.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime > /dev/null
+ xdg-icon-resource forceupdate >/dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}