summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2021-12-23 19:29:43 +0300
committerOrhun Parmaksız2021-12-23 19:29:43 +0300
commit67ccba6d69fe5fdef1d7344768051e703821560e (patch)
treef6c98c95ab03fe6078da8b39300300edd43efd67
parentdd5d9c843f8dc5cf29c2b05aa49e07d9c777755f (diff)
downloadaur-67ccba6d69fe5fdef1d7344768051e703821560e.tar.gz
upgpkg: atuin-git 0.8.0.r3.g7fa3e1c0-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d89cb8ab2446..d8cf1e014caa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = atuin-git
pkgdesc = Magical shell history (git)
- pkgver = 0.7.2.r6.gb549095d
+ pkgver = 0.8.0.r3.g7fa3e1c0
pkgrel = 1
url = https://github.com/ellie/atuin
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = atuin-git
depends = gcc-libs
provides = atuin
conflicts = atuin
+ options = !lto
source = git+https://github.com/ellie/atuin
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f35874103b6e..95f100e487a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=atuin-git
-pkgver=0.7.2.r6.gb549095d
+pkgver=0.8.0.r3.g7fa3e1c0
pkgrel=1
pkgdesc="Magical shell history (git)"
arch=('x86_64')
@@ -14,6 +14,7 @@ conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+${url}")
sha256sums=('SKIP')
+options=('!lto')
pkgver() {
cd "${pkgname%-git}"
@@ -23,11 +24,15 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
cargo fetch --locked
+ mkdir completions/
}
build() {
cd "${pkgname%-git}"
cargo build --release --frozen
+ for sh in 'bash' 'fish' 'zsh'; do
+ "target/release/${pkgname%-git}" gen-completions -s "$sh" -o completions/
+ done
}
check() {
@@ -40,4 +45,7 @@ package() {
install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm 644 "completions/${pkgname%-git}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-git}"
+ install -Dm 644 "completions/${pkgname%-git}.fish" -t "${pkgdir}/usr/share/fish/vendor_completions.d"
+ install -Dm 644 "completions/_${pkgname%-git}" -t "${pkgdir}/usr/share/zsh/site-functions"
}