summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lange2015-06-09 23:50:29 +0200
committerThomas Lange2015-06-09 23:50:29 +0200
commit150810e1e61d4133c07d14be3f387aed2564a2ee (patch)
tree2130622b8a2bffa43a7aa03e380ac9c56ad056e6
downloadaur-150810e1e61d4133c07d14be3f387aed2564a2ee.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--audacious-git.install22
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..a9cd95e5ed4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = audacious-git
+ pkgdesc = Lightweight, advanced audio player focused on audio quality
+ pkgver = 2015.06.09
+ pkgrel = 1
+ url = http://audacious-media-player.org/
+ install = audacious-git.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2
+ makedepends = git
+ depends = gtk2
+ depends = libguess
+ depends = libsm
+ depends = gnome-icon-theme
+ depends = desktop-file-utils
+ optdepends = unzip: zipped skins support
+ provides = audacious
+ conflicts = audacious
+ source = git://github.com/audacious-media-player/audacious.git
+ sha256sums = SKIP
+
+pkgname = audacious-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..a5873bd7428
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id$
+# Maintainer: Radioactiveman <thomas-lange2@gmx.de>
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Alexander Fehr <pizzapunk gmail com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+# To enable Qt support, uncomment the additional dependencies and "--enable-qt".
+# Do the same with audacious-plugins-git. Then run Audacious by "audacious --qt".
+
+pkgname=audacious-git
+pkgver=2015.06.09
+pkgrel=1
+pkgdesc="Lightweight, advanced audio player focused on audio quality"
+arch=('i686' 'x86_64')
+url="http://audacious-media-player.org/"
+license=('BSD')
+depends=('gtk2' 'libguess' 'libsm' 'gnome-icon-theme' 'desktop-file-utils')
+ # 'qt5-base' 'libxkbcommon-x11')
+makedepends=('python2' 'git') # for gdbus-codegen
+optdepends=('unzip: zipped skins support')
+provides=('audacious')
+conflicts=('audacious')
+install=$pkgname.install
+source=('git://github.com/audacious-media-player/audacious.git') # #branch=gtk3')
+sha256sums=('SKIP')
+
+pkgver() {
+ date +%Y.%m.%d
+}
+
+build() {
+ cd "$srcdir/audacious"
+
+ autoreconf -I m4
+ ./configure \
+ --prefix=/usr \
+ --with-buildstamp="$(date +%x)" \
+ # --enable-qt \
+
+ make
+}
+
+package() {
+ cd "$srcdir/audacious"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/audacious/LICENSE"
+}
diff --git a/audacious-git.install b/audacious-git.install
new file mode 100644
index 00000000000..806b2fc879e
--- /dev/null
+++ b/audacious-git.install
@@ -0,0 +1,22 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ echo
+ echo "------------------------------------------------"
+ echo " You need to install audacious-plugins-git now. "
+ echo " It cannot be added as dependency because "
+ echo " this would cause a circular dependency. "
+ echo "------------------------------------------------"
+ echo
+}
+
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}