summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome M. BERGER2015-08-30 17:39:31 +0200
committerJerome M. BERGER2015-08-30 17:39:31 +0200
commit0c0ba0fb7e8d4bd9f317a47896ccbc2d721ce2aa (patch)
tree5a299d12aac2f6d83c38c0b1c804662e5686eb99
parent79c59a8e8211b39454dd2471b931b4bcc1ad6abf (diff)
downloadaur-0c0ba0fb7e8d4bd9f317a47896ccbc2d721ce2aa.tar.gz
Updated to the new official github repository and version scheme.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59341f34fa9e..5c4ba0553d14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = audacious-imms-git
pkgdesc = An intelligent playlist plug-in for XMMS that tracks your listening patterns and dynamically adapts to your taste.
- pkgver = r249.4a395da
+ pkgver = 3.1.16.4227360
pkgrel = 1
url = https://sites.google.com/a/luminal.org/imms/
arch = i686
@@ -15,7 +15,7 @@ pkgbase = audacious-imms-git
depends = torch
conflicts = audacious-imms
replaces = imms
- source = git+https://github.com/jlindgren90/imms.git
+ source = git+https://github.com/martingkelly/imms.git
md5sums = SKIP
pkgname = audacious-imms-git
diff --git a/PKGBUILD b/PKGBUILD
index ccb1a0342575..885d35b7c655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jerome M. Berger <jeberger@free.fr>
pkgname=audacious-imms-git
-pkgver=r249.4a395da
+pkgver=3.1.16.4227360
pkgrel=1
pkgdesc="An intelligent playlist plug-in for XMMS that tracks your listening patterns and dynamically adapts to your taste."
arch=(i686 x86_64)
@@ -10,17 +10,29 @@ url="https://sites.google.com/a/luminal.org/imms/"
depends=('audacious' 'pcre' 'sqlite3' 'taglib' 'glib2' 'sox' 'torch')
replaces=('imms')
conflicts=('audacious-imms')
-source=(git+https://github.com/jlindgren90/imms.git)
+source=(git+https://github.com/martingkelly/imms.git)
md5sums=(SKIP)
pkgver() {
cd "${srcdir}/imms"
( set -o pipefail
- git describe --long 2>/dev/null | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ LATEST_TAG=$(git tag | grep -Exe 'imms-[0-9]+(\.[0-9]+)?' | sort -rn | head -1)
+ COMMITS_SINCE=$(git rev-list ${LATEST_TAG}..HEAD --count)
+ LATEST_VERSION=${LATEST_TAG#imms-}
+ if [ $COMMITS_SINCE == 0 ]; then
+ echo $LATEST_VERSION
+ else
+ echo ${LATEST_VERSION}.${COMMITS_SINCE}.$(git rev-parse --short HEAD)
+ fi
)
}
+prepare() {
+ cd $srcdir/imms/imms
+
+ echo "m4_define([GIT_VERSION], [$pkgver])" > gitversion.m4
+}
+
build() {
cd $srcdir/imms/imms