summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lange2020-12-16 00:49:59 +0100
committerThomas Lange2020-12-16 00:49:59 +0100
commit09562f2a36c106d19273a3de24744d36b611fcfe (patch)
tree2e33f7825708129a384e818cd5c635b93d847139
parent3c02eebf738264ce52a976183677b0f7848b7e20 (diff)
downloadaur-09562f2a36c106d19273a3de24744d36b611fcfe.tar.gz
Add config option for Meson
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD28
2 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 612cdc262c07..596aa5c49a11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = audacious-plugins-git
pkgdesc = Plugins for Audacious (git version)
- pkgver = 4.0.beta1.r215.g6d8a86d3d
+ pkgver = 4.0.beta1.r265.gffa26ceb1
pkgrel = 1
epoch = 1
url = https://audacious-media-player.org/
diff --git a/PKGBUILD b/PKGBUILD
index 4ade7d6f9c58..54d65be34c1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,12 @@
# Contributor: Alexander Fehr <pizzapunk gmail com>
# Contributor: William Rea <sillywilly@gmail.com>
+# Set to 1 to use Meson build system
+_use_meson=0
+
_pkgname=audacious-plugins
pkgname="$_pkgname-git"
-pkgver=4.0.beta1.r215.g6d8a86d3d
+pkgver=4.0.beta1.r265.gffa26ceb1
pkgrel=1
epoch=1
pkgdesc="Plugins for Audacious (git version)"
@@ -24,6 +27,10 @@ makedepends=('glib2' 'python' 'git')
source=("git://github.com/audacious-media-player/$_pkgname.git")
sha256sums=('SKIP')
+if [ "$_use_meson" = 1 ]; then
+ makedepends+=('meson')
+fi
+
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/^audacious-plugins-//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -32,13 +39,24 @@ pkgver() {
build() {
cd "$_pkgname"
- autoreconf -I m4
- ./configure --prefix=/usr
- make
+ if [ "$_use_meson" = 1 ]; then
+ arch-meson build
+ meson compile -C build
+ else
+ autoreconf -I m4
+ ./configure --prefix=/usr
+ make
+ fi
}
package() {
cd "$_pkgname"
- make DESTDIR="$pkgdir" install
+
+ if [ "$_use_meson" = 1 ]; then
+ DESTDIR="$pkgdir" meson install -C build
+ else
+ make DESTDIR="$pkgdir" install
+ fi
+
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}