summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBitts3112020-06-07 11:55:31 +0300
committerBitts3112020-06-07 11:55:31 +0300
commit162eca92f79ae77f5e688e5039da0aba744a996a (patch)
tree61914feedf1bcb24ac65fe2feee824278b16b459
downloadaur-162eca92f79ae77f5e688e5039da0aba744a996a.tar.gz
Initial import
-rw-r--r--.SRCINFO40
-rwxr-xr-xPKGBUILD37
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9701317b94d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = audacious-plugins-gtk
+ pkgdesc = Plugins for Audacious
+ pkgver = 4.0.4
+ pkgrel = 1
+ url = https://audacious-media-player.org/
+ arch = x86_64
+ license = BSD
+ license = GPL
+ depends = audacious
+ depends = glib2
+ depends = alsa-lib
+ depends = pulseaudio
+ depends = jack2
+ depends = lame
+ depends = libvorbis
+ depends = flac
+ depends = mpg123
+ depends = faad2
+ depends = ffmpeg
+ depends = libmodplug
+ depends = fluidsynth
+ depends = libcdio-paranoia
+ depends = libsidplayfp
+ depends = wavpack
+ depends = dbus-glib
+ depends = libsamplerate
+ depends = libnotify
+ depends = lirc
+ depends = curl
+ depends = libmtp
+ depends = neon
+ depends = libmms
+ depends = libcue
+ provides = audacious-plugins
+ conflicts = audacious-plugins
+ source = https://distfiles.audacious-media-player.org/audacious-plugins-4.0.4.tar.bz2
+ sha256sums = SKIP
+
+pkgname = audacious-plugins-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a51ea0811972
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+## To enable GTK support, uncomment the additional dependency and "--enable-gtk".
+## Do the same with audacious-plugins-git. Then run Audacious by "audacious --gtk".
+
+_pkgname=audacious-plugins
+pkgname=$_pkgname-gtk
+pkgver=4.0.4
+pkgrel=1
+pkgdesc="Plugins for Audacious"
+arch=('x86_64')
+url="https://audacious-media-player.org/"
+license=('BSD' 'GPL')
+provides=('audacious-plugins')
+conflicts=('audacious-plugins')
+depends=('audacious' 'glib2' 'alsa-lib' 'pulseaudio' 'jack2' 'lame' 'libvorbis' 'flac' 'mpg123' 'faad2' 'ffmpeg' 'libmodplug' 'fluidsynth' 'libcdio-paranoia' 'libsidplayfp' 'wavpack' 'dbus-glib' 'libsamplerate' 'libnotify' 'lirc' 'curl' 'libmtp' 'neon' 'libmms' 'libcue')
+source=("https://distfiles.audacious-media-player.org/audacious-plugins-4.0.4.tar.bz2")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ autoreconf -I m4
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --enable-gtk \
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+