summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Vorster2023-01-31 17:32:39 +0100
committerEvert Vorster2023-01-31 17:32:39 +0100
commit19903b2ea776ce4196d06064a42454d6cde066c6 (patch)
tree84438542aa14d6f8bb56e69a0a4fcc6be1530d5d
parentede5bf4499376b359bf33c44e804b1aecb0ecff6 (diff)
downloadaur-19903b2ea776ce4196d06064a42454d6cde066c6.tar.gz
Updated PKGBUILD to make more sensible version numbering
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec1dd7641d63..95a3c949f1f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = audacity-qt-git
pkgdesc = Record and edit audio files-tracking the QT branch in git
- pkgver = 3.1.3
+ pkgver = 3.3.0.0.r16557
pkgrel = 1
url = https://audacityteam.org
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index cbba9270a0e2..ff817a668f14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: osch <oliver@luced.de>
pkgname=audacity-qt-git
-pkgver=3.1.3
+pkgver=3.3.0.0.r16557
pkgrel=1
pkgdesc="Record and edit audio files-tracking the QT branch in git"
arch=('x86_64')
@@ -21,6 +21,16 @@ source=(
)
sha512sums=('SKIP')
+pkgver() {
+ cd ${srcdir}/audacity
+ VERSION=$(grep AUDACITY_VERSION CMakeLists.txt | head -n 1 | cut -d " " -f3)
+ RELEASE=$(grep AUDACITY_RELEASE CMakeLists.txt | head -n 1 | cut -d " " -f3)
+ REVISION=$(grep AUDACITY_REVISION CMakeLists.txt | head -n 1 | cut -d " " -f3)
+ MODLEVEL=$(grep AUDACITY_MODLEVEL CMakeLists.txt | head -n 1 | cut -d " " -f3)
+ _ver=$VERSION.$RELEASE.$REVISION.$MODLEVEL
+ echo "$(echo ${_ver}).r$(git rev-list --count HEAD)"
+}
+
prepare() {
# cd "audacity-Audacity-${pkgver}"
# sed -i -e '/#include <iterator>/i #include <limits>' libraries/lib-utility/MemoryX.h