summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Vorster2023-01-16 10:37:36 +0200
committerEvert Vorster2023-01-16 10:37:36 +0200
commitede5bf4499376b359bf33c44e804b1aecb0ecff6 (patch)
tree881ba66c6f4173f3c944e61408e16651468861c1
downloadaur-ede5bf4499376b359bf33c44e804b1aecb0ecff6.tar.gz
Initial commit
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD66
2 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec1dd7641d63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+pkgbase = audacity-qt-git
+ pkgdesc = Record and edit audio files-tracking the QT branch in git
+ pkgver = 3.1.3
+ pkgrel = 1
+ url = https://audacityteam.org
+ arch = x86_64
+ groups = pro-audio
+ license = GPL2
+ license = CCPL
+ makedepends = cmake
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = libtool
+ makedepends = git
+ makedepends = conan
+ makedepends = catch2
+ depends = libmad
+ depends = libid3tag
+ depends = gtk2
+ depends = glib2
+ depends = soundtouch
+ depends = ffmpeg
+ depends = vamp-plugin-sdk
+ depends = portsmf
+ depends = portmidi
+ depends = twolame
+ depends = suil
+ depends = lilv
+ depends = lv2
+ depends = serd
+ depends = sord
+ depends = sratom
+ depends = python
+ depends = flac
+ depends = libvorbis
+ depends = libogg
+ depends = vamp-plugin-sdk
+ depends = portaudio
+ depends = libsoxr
+ depends = libsndfile
+ depends = lame
+ depends = expat
+ depends = alsa-lib
+ depends = jack
+ depends = util-linux
+ depends = util-linux-libs
+ depends = curl
+ depends = zlib
+ provides = audacity
+ conflicts = audacity
+ source = git+https://github.com/audacity/audacity.git#branch=qt
+ sha512sums = SKIP
+
+pkgname = audacity-qt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbba9270a0e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: evorster <evorster@gmail.com>
+# Contributor: osch <oliver@luced.de>
+
+pkgname=audacity-qt-git
+pkgver=3.1.3
+pkgrel=1
+pkgdesc="Record and edit audio files-tracking the QT branch in git"
+arch=('x86_64')
+url="https://audacityteam.org"
+license=('GPL2' 'CCPL')
+groups=('pro-audio')
+depends=('libmad' 'libid3tag' 'gtk2' 'glib2' 'soundtouch' 'ffmpeg' 'vamp-plugin-sdk'
+'portsmf' 'portmidi' 'twolame' 'suil' 'lilv' 'lv2' 'serd' 'sord' 'sratom' 'python'
+'flac' 'libvorbis' 'libogg' 'vamp-plugin-sdk' 'portaudio' 'libsoxr' 'libsndfile' 'lame'
+'expat' 'alsa-lib' 'jack' 'util-linux' 'util-linux-libs' 'curl' 'zlib')
+makedepends=('cmake' 'autoconf' 'automake' 'libtool' 'git' 'conan' 'catch2')
+provides=("audacity")
+conflicts=("audacity")
+source=(
+"git+https://github.com/audacity/audacity.git#branch=qt"
+)
+sha512sums=('SKIP')
+
+prepare() {
+# cd "audacity-Audacity-${pkgver}"
+# sed -i -e '/#include <iterator>/i #include <limits>' libraries/lib-utility/MemoryX.h
+ mkdir -p build
+ cd build
+ depsDir=$(readlink -f ./.offline)
+ export CONAN_USER_HOME="$depsDir/conan"
+ conan config home
+ conan config init
+ conan config set storage.download_cache="$CONAN_USER_HOME/download_cache"
+ conan remove "*" --src --builds --force
+ cmake -G "Unix Makefiles" ../audacity \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Daudacity_use_ffmpeg=loaded \
+ -Daudacity_has_vst3=Off
+# -DAUDACITY_BUILD_LEVEL=2 \
+# -Daudacity_has_networking=off \
+# -Daudacity_lib_preference=system local \
+# -Daudacity_use_expat=system \
+# -Daudacity_use_zlib=system \
+# -Daudacity_use_curl=system \
+# -Daudacity_use_portmidi=local \
+# -Daudacity_use_wxwidgets=local \
+
+}
+
+build() {
+#pwd
+cd build
+# cd "audacity-Audacity-${pkgver}"/build
+ make
+ conan remove "*" --src --builds --force
+}
+
+package() {
+make -C build DESTDIR="${pkgdir}" install
+# cd "audacity-Audacity-${pkgver}"/build
+# make DESTDIR="${pkgdir}" install
+# rm "${pkgdir}"/usr/audacity
+# chmod -R go=u "${pkgdir}"
+# chmod -R go-w "${pkgdir}"
+}