summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2018-06-22 09:58:14 +0200
committerosch2018-06-22 09:58:14 +0200
commit68c766d316ffa0675fe04c1c571c8bed60758715 (patch)
tree0f3f75651f788c6f17263b08c2caf3bab36b944d
downloadaur-68c766d316ffa0675fe04c1c571c8bed60758715.tar.gz
initial
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ada24b835e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = audacity-wxgtk2
+ pkgdesc = A program that lets you manipulate digital audio waveforms
+ pkgver = 2.2.2
+ pkgrel = 3
+ url = https://audacityteam.org
+ arch = x86_64
+ groups = pro-audio
+ license = GPL2
+ license = CCPL
+ makedepends = cmake
+ depends = libmad
+ depends = libid3tag
+ depends = wxgtk2
+ depends = soundtouch
+ depends = ffmpeg
+ depends = vamp-plugin-sdk
+ depends = portsmf
+ depends = twolame
+ depends = suil
+ depends = lilv
+ provides = audacity
+ conflicts = audacity
+ source = https://github.com/audacity/audacity/archive/Audacity-2.2.2.tar.gz
+ sha512sums = 311a5f3413e7faf40dc5639b2b9f8b0d03d1a410c50d894ca7abf3fe5733a29b710ccf7e3215d97dd9142e93c0ab5e13955dfd13146b03f927f74465459a6457
+
+pkgname = audacity-wxgtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec683798e7ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: osch <oliver@luced.de>
+
+pkgname=audacity-wxgtk2
+pkgver=2.2.2
+pkgrel=3
+pkgdesc="Record and edit audio files"
+arch=('x86_64')
+url="https://audacityteam.org"
+license=('GPL2' 'CCPL')
+groups=('pro-audio')
+depends=('libmad' 'libid3tag' 'wxgtk2' 'soundtouch' 'ffmpeg' 'vamp-plugin-sdk'
+'portsmf' 'twolame' 'suil' 'lilv')
+makedepends=('cmake')
+provides=("audacity")
+conflicts=("audacity")
+source=("https://github.com/audacity/audacity/archive/Audacity-${pkgver}.tar.gz")
+sha512sums=('311a5f3413e7faf40dc5639b2b9f8b0d03d1a410c50d894ca7abf3fe5733a29b710ccf7e3215d97dd9142e93c0ab5e13955dfd13146b03f927f74465459a6457')
+
+prepare() {
+ mv -v "audacity-Audacity-${pkgver}" "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
+ autoreconf -vi
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ WX_CONFIG=wx-config ./configure --prefix="/usr" \
+ --with-libsndfile="system" \
+ --with-ffmpeg="system" \
+ --with-expat="system" \
+ --with-lame="system" \
+ --with-libsoxr="system" \
+ --with-libflac \
+ --with-libid3tag \
+ --with-libsamplerate \
+ --with-sbsms \
+ --with-soundtouch \
+ --with-libtwolame \
+ --with-libvorbis \
+ --with-lv2 \
+ --with-portaudio \
+ --with-portmidi
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+sha512sums=('311a5f3413e7faf40dc5639b2b9f8b0d03d1a410c50d894ca7abf3fe5733a29b710ccf7e3215d97dd9142e93c0ab5e13955dfd13146b03f927f74465459a6457')