summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2021-11-01 11:33:06 +0100
committerosch2021-11-01 11:33:06 +0100
commit71307be9c5fa0549eab52bf759c6c1a6f1c7c06a (patch)
tree665d0b8f99ba98dab2b8e42ec4546f55a7c489df
parentd14c0f274d28b3e02a29becd5f69f22f1601e786 (diff)
downloadaur-71307be9c5fa0549eab52bf759c6c1a6f1c7c06a.tar.gz
Audacity 3.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b4fd453026b..d1b74947be59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = audacity-wxgtk2
pkgdesc = Record and edit audio files
- pkgver = 3.0.5
+ pkgver = 3.1.0
pkgrel = 1
url = https://audacityteam.org
arch = x86_64
@@ -42,9 +42,12 @@ pkgbase = audacity-wxgtk2
depends = alsa-lib
depends = jack
depends = util-linux
+ depends = util-linux-libs
+ depends = curl
+ depends = zlib
provides = audacity
conflicts = audacity
- source = https://github.com/audacity/audacity/archive/Audacity-3.0.5.tar.gz
- sha512sums = d7585bf1b1715e54a79ab2c940dca91ec3041a97f02c5483eff9321bb7375401f868b7c394e06cf5e956017974ce21a0f0203c84d3a9b71745deb9a698b79131
+ source = https://github.com/audacity/audacity/archive/Audacity-3.1.0.tar.gz
+ sha512sums = ddaad6af31fc96357fdb3f1f8b5e8039c4158545e472bcac01440ae0b0ed54d7839b84b756b13f23c013bac93da8753064194452e4d29fd73a74ec36f1394d88
pkgname = audacity-wxgtk2
diff --git a/PKGBUILD b/PKGBUILD
index 06e7f05f1daf..643d2098c4a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: osch <oliver@luced.de>
pkgname=audacity-wxgtk2
-pkgver=3.0.5
+pkgver=3.1.0
pkgrel=1
pkgdesc="Record and edit audio files"
arch=('x86_64')
@@ -11,31 +11,36 @@ groups=('pro-audio')
depends=('libmad' 'libid3tag' 'gtk2' 'glib2' 'soundtouch' 'ffmpeg' 'vamp-plugin-sdk'
'portsmf' 'portmidi' 'twolame' 'suil' 'lilv' 'lv2' 'serd' 'sord' 'sratom' 'python'
'flac' 'libvorbis' 'libogg' 'vamp-plugin-sdk' 'portaudio' 'libsoxr' 'libsndfile' 'lame'
-'expat' 'alsa-lib' 'jack' 'util-linux')
+'expat' 'alsa-lib' 'jack' 'util-linux' 'util-linux-libs' 'curl' 'zlib')
makedepends=('cmake' 'autoconf' 'automake' 'libtool' 'git' 'conan')
provides=("audacity")
conflicts=("audacity")
source=("https://github.com/audacity/audacity/archive/Audacity-${pkgver}.tar.gz")
-sha512sums=('d7585bf1b1715e54a79ab2c940dca91ec3041a97f02c5483eff9321bb7375401f868b7c394e06cf5e956017974ce21a0f0203c84d3a9b71745deb9a698b79131')
+sha512sums=('ddaad6af31fc96357fdb3f1f8b5e8039c4158545e472bcac01440ae0b0ed54d7839b84b756b13f23c013bac93da8753064194452e4d29fd73a74ec36f1394d88')
prepare() {
cd "audacity-Audacity-${pkgver}"
sed -i -e '/#include <iterator>/i #include <limits>' libraries/lib-utility/MemoryX.h
mkdir -p build
cd build
+ conan remove "*" --src --builds --force
cmake -G "Unix Makefiles" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DAUDACITY_BUILD_LEVEL=2 \
- -Daudacity_use_ffmpeg=loaded \
-Daudacity_has_networking=off \
- -Daudacity_conan_enabled=off \
+ -Daudacity_lib_preference=system \
+ -Daudacity_use_expat=system \
+ -Daudacity_use_ffmpeg=loaded \
+ -Daudacity_use_zlib=system \
+ -Daudacity_use_curl=system \
..
}
build() {
cd "audacity-Audacity-${pkgver}"/build
make
+ conan remove "*" --src --builds --force
}
package() {