summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2021-07-01 22:53:49 +0200
committerosch2021-07-01 22:53:49 +0200
commit865aa4d43fac0e2657cf06e1e2d0019c286b3472 (patch)
tree3e49213c96f689ce370811d65f1f05a4bb877620
parent93e23027095bb8710bbe2b0807196d789bf67d85 (diff)
downloadaur-865aa4d43fac0e2657cf06e1e2d0019c286b3472.tar.gz
Resolving error: "Internal error at audacity-wxgtk2-3.0.2/src/DBConnection.cpp line 410."
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ba7434bc2c1..a714756e6781 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = audacity-wxgtk2
pkgdesc = Record and edit audio files
pkgver = 3.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://audacityteam.org
arch = x86_64
groups = pro-audio
diff --git a/PKGBUILD b/PKGBUILD
index a161c809fe73..4366758d8f5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=audacity-wxgtk2
pkgver=3.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Record and edit audio files"
arch=('x86_64')
url="https://audacityteam.org"
@@ -21,9 +21,12 @@ sha512sums=('1ea5b84b3938a448c4ab3b6a97432e4fb59f62d14f65f277047258c473501952ed5
prepare() {
mv -v "audacity-Audacity-${pkgver}" "${pkgname}-${pkgver}"
cd "${pkgname}-${pkgver}"
+ sed -i -e 's:--recurse-submodules:--recurse-submodules --branch v3.1.3.1-audacity:' cmake-proxies/wxWidgets/CMakeLists.txt
+ sed -i -e '/#include <algorithm>/i #include <limits>' include/audacity/Types.h
mkdir build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -Daudacity_use_ffmpeg=loaded -Daudacity_use_wxwidgets=local ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -Daudacity_use_ffmpeg=loaded \
+ -Daudacity_use_wxwidgets=local -Daudacity_use_sqlite=local ..
}
build() {