summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2021-07-14 21:10:01 -0400
committerEthan Kerrick2021-07-14 21:10:01 -0400
commit931f0897e33af8af7486ba649953aa3e317c412c (patch)
tree887522fdef5e77b478a4b834682c3b640984cecf
parent908d56f33b96e143ab13b97e5744c2e082589fc6 (diff)
downloadaur-931f0897e33af8af7486ba649953aa3e317c412c.tar.gz
add gtk2 to make depends, cleaned up unused values and changed version scheme to comply with vcs guidelines
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 657a01ad5e3c..1a486ec545bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = audacium-git
pkgdesc = telemetry free version of audacity
- pkgver = 78c701d.r1.gd032c3102
- pkgrel = 1
+ pkgver = 2.4.1.r1696.ge44c8911b
+ pkgrel = 2
+ epoch = 1
url = https://github.com/SartoxOnlyGNU/audacium
arch = x86_64
license = GPL2
@@ -15,6 +16,7 @@ pkgbase = audacium-git
makedepends = jack
makedepends = nasm
makedepends = conan
+ makedepends = gtk2
depends = alsa-lib
depends = libx11
depends = gtk3
@@ -40,4 +42,3 @@ pkgbase = audacium-git
md5sums = SKIP
pkgname = audacium-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 30849fa1cc82..75984d4d9a96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,23 @@
# Maintainer: silverhikari
pkgname=audacium-git
-pkgver=78c701d.r1.gd032c3102
-pkgrel=1
-epoch=
+pkgver=2.4.1.r1696.ge44c8911b
+pkgrel=2
+epoch=1
pkgdesc="telemetry free version of audacity"
arch=(x86_64)
url="https://github.com/SartoxOnlyGNU/audacium"
license=('GPL2')
groups=()
depends=(alsa-lib libx11 gtk3 expat libid3tag libogg libsndfile libvorbis lilv lv2 portsmf suil libmad twolame vamp-plugin-sdk libsoxr soundtouch ffmpeg)
-makedepends=(git cmake sdl2 libsoup libnotify gstreamer gst-plugins-bad-libs jack nasm conan)
-checkdepends=()
-optdepends=()
+makedepends=(git cmake sdl2 libsoup libnotify gstreamer gst-plugins-bad-libs jack nasm conan gtk2)
provides=('audacity')
conflicts=('audacity' 'audacity-git')
-replaces=()
-backup=()
-options=()
-install=
-changelog=
source=('git+https://github.com/SartoxOnlyGNU/audacium')
md5sums=('SKIP')
pkgver() {
cd "audacium"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/^Audacity.//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {