summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor3D2020-05-24 19:41:17 +0300
committerVictor3D2020-05-24 19:41:17 +0300
commit3c26d1d40b6d990c3a7c4b00fe153b4b921a7f18 (patch)
tree84989a7efc9d3b6b2ff6d77e2065e48323dd0faf
downloadaur-audio-m4p.tar.gz
New
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd4479c67281
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = audio-m4p
+ pkgdesc = Read-only release history for Audio-M4P
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/gitpan/Audio-M4P
+ arch = any
+ license = GPL-2.0
+ makedepends = git
+ depends = perl
+ source = git+https://github.com/gitpan/Audio-M4P
+ md5sums = SKIP
+
+pkgname = audio-m4p
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e008717f2db7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Victor Perevozchikov webmaster@victor3d.com.br
+pkgname=audio-m4p
+pkgver=1
+pkgrel=1
+pkgdesc='Read-only release history for Audio-M4P'
+arch=('any')
+url="https://github.com/gitpan/Audio-M4P"
+license=('GPL-2.0')
+depends=('perl')
+makedepends=('git')
+source=('git+https://github.com/gitpan/Audio-M4P')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/Audio-M4P"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/Audio-M4P"
+perl Makefile.PL
+make
+make test
+make install
+}