summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2017-05-05 13:37:11 +0200
committerChristopher Arndt2017-05-05 13:37:11 +0200
commit1013ebe6fb906df005d6be19a06fd3815aba3b8c (patch)
tree24795bb7c394d972c7093a5d3d6be4c27a1245ae
parentd49c17559b118d253f91665137ee0d962edec1df (diff)
downloadaur-1013ebe6fb906df005d6be19a06fd3815aba3b8c.tar.gz
Fix docs building and version number detection
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
-rw-r--r--audiotk-cmakelists.diff22
3 files changed, 44 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db040c8d4a9f..9d5f4a9c5c0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 27 20:05:06 UTC 2016
+# Fri May 5 11:36:25 UTC 2017
pkgbase = audiotk-git
pkgdesc = A C++ library plus Python 3 bindings with a set of audio filters (git version)
- pkgver = 1.2.0.r808.0af35fc
+ pkgver = 2.0.2.r1502.305ee21
pkgrel = 1
url = https://github.com/mbrucher/AudioTK
arch = i686
@@ -16,7 +16,9 @@ pkgbase = audiotk-git
provides = audiotk
conflicts = audiotk
source = audiotk::git+https://github.com/mbrucher/AudioTK.git
+ source = audiotk-cmakelists.diff
md5sums = SKIP
+ md5sums = 9ba195731f5d64b58e668639b7e0bfe8
pkgname = audiotk-git
diff --git a/PKGBUILD b/PKGBUILD
index 79ef12c803d3..aa50caeb6530 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=audiotk
pkgname="${_pkgname}-git"
-pkgver=1.2.0.r808.0af35fc
+pkgver=2.0.2.r1502.305ee21
pkgrel=1
pkgdesc="A C++ library plus Python 3 bindings with a set of audio filters (git version)"
arch=('i686' 'x86_64')
@@ -10,17 +10,19 @@ license=('BSD')
url='https://github.com/mbrucher/AudioTK'
depends=('fftw' 'libsndfile' 'python')
makedepends=('git' 'cmake')
-source=("${_pkgname}::git+https://github.com/mbrucher/AudioTK.git")
+source=("${_pkgname}::git+https://github.com/mbrucher/AudioTK.git"
+ 'audiotk-cmakelists.diff')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '9ba195731f5d64b58e668639b7e0bfe8')
pkgver() {
cd "${srcdir}/${_pkgname}"
- version="$(git describe --tags | sed -e 's/^[^-]*-//;s/-.*//')"
- revision=$(git rev-list --count HEAD)
- hash=$(git rev-parse --short HEAD)
+ local version="$(grep ^PROJECT_NUMBER Doxyfile | awk '{ print $3 }')"
+ local revision=$(git rev-list --count HEAD)
+ local hash=$(git rev-parse --short HEAD)
echo $version.r$revision.$hash
}
@@ -33,6 +35,7 @@ prepare() {
mkdir build
git checkout develop
+ patch -p1 -i "${srcdir}/audiotk-cmakelists.diff"
}
build() {
@@ -45,8 +48,15 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_PYTHON=1 \
-DPYTHON_INSTALL_FOLDER=/usr/lib/python${py_ver} \
- -DENABLE_TESTS=1
- make DESTDIR="${pkgdir}"
+ -DENABLE_TESTS=1 \
+ -DBUILD_DOC=1
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}/build"
+
+ make test
}
package() {
diff --git a/audiotk-cmakelists.diff b/audiotk-cmakelists.diff
new file mode 100644
index 000000000000..0888990a0daa
--- /dev/null
+++ b/audiotk-cmakelists.diff
@@ -0,0 +1,22 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f273543..c698cdc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -158,7 +158,7 @@ else(WIN32)
+ else(COMPILER_SUPPORTS_ftpz)
+ message(STATUS "The compiler ${CMAKE_CXX_COMPILER} doesn't support -fdenormal-fp-math=positive-zero.")
+ endif(COMPILER_SUPPORTS_ftpz)
+-
++
+ CHECK_CXX_COMPILER_FLAG("-ftree-vectorize -ftree-vectorizer-verbose=2" COMPILER_SUPPORTS_ftree_vectorize)
+ if(COMPILER_SUPPORTS_ftree_vectorize)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -ftree-vectorize -ftree-vectorizer-verbose=2")
+@@ -334,7 +334,7 @@ endif(ENABLE_PYTHON)
+
+ IF (BUILD_DOC)
+
+- FIND_PACKAGE(Doxygen Required)
++ FIND_PACKAGE(Doxygen REQUIRED)
+
+ SET(DOXYGEN_INPUT Doxyfile)
+ SET(DOXYGEN_OUTPUT Doxygen)