summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-03-27 22:05:14 +0200
committerChristopher Arndt2016-03-27 22:05:14 +0200
commitd49c17559b118d253f91665137ee0d962edec1df (patch)
tree41159993cd5350c5b57ec79c65ee27e637259941
parentf3325c9b3547afd4fb94f9f67de213b7aeb46944 (diff)
downloadaur-d49c17559b118d253f91665137ee0d962edec1df.tar.gz
Added API docs and examples; removed patch for fixed github issue #4; changed pkgdesc slightly
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--audiotk-git_h.patch12
3 files changed, 13 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c592a90bacdc..db040c8d4a9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 27 07:33:20 UTC 2016
+# Sun Mar 27 20:05:06 UTC 2016
pkgbase = audiotk-git
- pkgdesc = A C++ library with a set of audio filters (git version)
- pkgver = 1.1.0.r803.12b0a3a
+ pkgdesc = A C++ library plus Python 3 bindings with a set of audio filters (git version)
+ pkgver = 1.2.0.r808.0af35fc
pkgrel = 1
url = https://github.com/mbrucher/AudioTK
arch = i686
@@ -16,9 +16,7 @@ pkgbase = audiotk-git
provides = audiotk
conflicts = audiotk
source = audiotk::git+https://github.com/mbrucher/AudioTK.git
- source = audiotk-git_h.patch
md5sums = SKIP
- md5sums = bfb36a2eb0f771271cdd96bc9217a777
pkgname = audiotk-git
diff --git a/PKGBUILD b/PKGBUILD
index 3550729cd1ca..79ef12c803d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,19 @@
_pkgname=audiotk
pkgname="${_pkgname}-git"
-pkgver=1.1.0.r803.12b0a3a
+pkgver=1.2.0.r808.0af35fc
pkgrel=1
-pkgdesc="A C++ library with a set of audio filters (git version)"
+pkgdesc="A C++ library plus Python 3 bindings with a set of audio filters (git version)"
arch=('i686' 'x86_64')
license=('BSD')
url='https://github.com/mbrucher/AudioTK'
depends=('fftw' 'libsndfile' 'python')
makedepends=('git' 'cmake')
-source=("${_pkgname}::git+https://github.com/mbrucher/AudioTK.git"
- 'audiotk-git_h.patch')
+source=("${_pkgname}::git+https://github.com/mbrucher/AudioTK.git")
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-md5sums=('SKIP'
- 'bfb36a2eb0f771271cdd96bc9217a777')
+md5sums=('SKIP')
+
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -34,8 +33,6 @@ prepare() {
mkdir build
git checkout develop
-
- patch -p1 -r - -i "${srcdir}/audiotk-git_h.patch"
}
build() {
@@ -57,7 +54,11 @@ package() {
make DESTDIR="${pkgdir}" install
- install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ..
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -r Examples "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -r Doxygen/html "${pkgdir}/usr/share/doc/${pkgname}/API"
}
# vim:set ts=2 sw=2 et:
diff --git a/audiotk-git_h.patch b/audiotk-git_h.patch
deleted file mode 100644
index edb333440e7b..000000000000
--- a/audiotk-git_h.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/tests/Distortion/SimpleOverdriveFilter.cpp b/tests/Distortion/SimpleOverdriveFilter.cpp
-index 61f16cd..24f1397 100644
---- a/tests/Distortion/SimpleOverdriveFilter.cpp
-+++ b/tests/Distortion/SimpleOverdriveFilter.cpp
-@@ -3,7 +3,6 @@
- */
-
- #include <ATK/config.h>
--#include <ATK/git.h>
-
- #include <ATK/Distortion/SimpleOverdriveFilter.h>
-