summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-16 08:54:57 +0100
committerGustavo Alvarez2016-01-16 08:54:57 +0100
commitfb0f193691e362f2413f63f674375dccd519482e (patch)
tree75a871321510904ad74eaa368592ff974c68adc7
downloadaur-fb0f193691e362f2413f63f674375dccd519482e.tar.gz
Initial commit
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD71
3 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13ba61a1158c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by mksrcinfo v8
+# Sat Jan 16 07:54:57 UTC 2016
+pkgbase = audiotools-git
+ pkgdesc = Collection of audio handling programs which work from the command line (GIT Version)
+ pkgver = v3.1.1.117.gb40b6cc
+ pkgrel = 1
+ url = http://audiotools.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = python-distribute
+ depends = python
+ depends = libcdio-paranoia
+ depends = libpulse
+ depends = opusfile
+ depends = twolame
+ depends = mpg123
+ depends = lame
+ depends = wavpack
+ depends = libdvd-audio-git
+ optdepends = faad2: Decoding AAC
+ optdepends = faac: Encoding AAC
+ optdepends = neroaacdec: Decoding AAC (preferred)
+ optdepends = neroaacenc: Encoding AAC (preferred)
+ optdepends = mp3gain: For MP3 Replay Gain support
+ optdepends = vorbisgain: For OGG Replay Gain support
+ optdepends = python-pillow: for Coverview interface
+ optdepends = pygtk: for Coverview interface (GTK)
+ optdepends = python-pmw: Coverview interface (Tk)
+ optdepends = python-urwid: interactive modes
+ optdepends = cdrkit: for CD burning without cuesheets
+ optdepends = cdrecord: for CD burning without cuesheets
+ optdepends = cdrdao: for CD burning with cuesheets
+ provides = audio-tools
+ conflicts = audio-tools
+ source = git+https://github.com/tuffy/python-audio-tools.git
+ sha1sums = SKIP
+
+pkgname = audiotools-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..691ce0af6c78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Guatavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=audiotools-git
+pkgver=v3.1.1.117.gb40b6cc
+pkgrel=1
+pkgdesc="Collection of audio handling programs which work from the command line (GIT Version)"
+arch=('i686' 'x86_64')
+url="http://audiotools.sourceforge.net"
+license=('GPL')
+depends=('python'
+ 'libcdio-paranoia'
+ 'libpulse'
+ 'opusfile'
+ 'twolame'
+ 'mpg123'
+ 'lame'
+ 'wavpack'
+ 'libdvd-audio-git'
+ )
+makedepends=('git'
+ 'python-distribute'
+ )
+optdepends=('faad2: Decoding AAC'
+ 'faac: Encoding AAC'
+ 'neroaacdec: Decoding AAC (preferred)'
+ 'neroaacenc: Encoding AAC (preferred)'
+ 'mp3gain: For MP3 Replay Gain support'
+ 'vorbisgain: For OGG Replay Gain support'
+ 'python-pillow: for Coverview interface'
+ 'pygtk: for Coverview interface (GTK)'
+ 'python-pmw: Coverview interface (Tk)'
+ 'python-urwid: interactive modes'
+ 'cdrkit: for CD burning without cuesheets'
+ 'cdrecord: for CD burning without cuesheets'
+ 'cdrdao: for CD burning with cuesheets'
+ )
+conflicts=('audio-tools')
+provides=('audio-tools')
+source=('git+https://github.com/tuffy/python-audio-tools.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd python-audio-tools
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd python-audio-tools
+ sed -e 's|cdio/cdda.h|cdio/paranoia/cdda.h|g' \
+ -e 's|cdio/paranoia.h|cdio/paranoia/paranoia.h|g' \
+ -i src/cdiomodule.h
+
+
+ sed -e 's|-m 644|-Dm 644|g' \
+ -e 's|all: $(TARGETS)|all: $(MAN_PAGES)|g' \
+ -i Makefile -i docs/Makefile
+}
+
+build() {
+ cd python-audio-tools
+ python setup.py build
+ cd docs
+ make
+}
+
+package() {
+ cd python-audio-tools
+ python setup.py install --root="${pkgdir}" --optimize=1
+ cd docs
+ make install MAN_PATH="${pkgdir}/usr/share/man"
+}