summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorsten Müller2022-09-21 17:53:24 +0200
committerThorsten Müller2022-09-21 17:53:24 +0200
commitacab72c760488b1d83d7239105b72a6a8f13c8c5 (patch)
treea2a7657c755bfb54ad0d9cd3eb29b4725eedc883
downloadaur-acab72c760488b1d83d7239105b72a6a8f13c8c5.tar.gz
install auditbeat-oss binary
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--auditbeat-oss.service16
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40c508bd01a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = auditbeat-oss-bin
+ pkgdesc = Data shippers for Elasticsearch
+ pkgver = 8.4.2
+ pkgrel = 1
+ url = https://www.elastic.co/products/beats
+ arch = x86_64
+ license = Apache
+ depends = glibc
+ conflicts = auditbeat-oss
+ backup = etc/auditbeat-oss/auditbeat.yml,
+ backup = etc/auditbeat-oss/fields.yml
+ source = https://artifacts.elastic.co/downloads/beats/auditbeat/auditbeat-8.4.2-linux-x86_64.tar.gz
+ source = auditbeat-oss.service
+ sha512sums = 8e65c3f4de1a8d35dd988ca39b38cb17c157ab18461a8fb97d96adccb3663406b9405db7255b982e3a8b7bac3ebe9b6624864b6aa42cc491ea8c35807781d8e1
+ sha512sums = 6c2b7ad706efbbaab55e2bd6a63dd85ee358aeed8255a829adeacdcd45d364520cc7f0328cfa966d61e911042d8fac40abc7ff36cdb7a834fc83df7da94fce13
+
+pkgname = auditbeat-oss-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b319e5721e71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thorsten Müller
+
+pkgname=auditbeat-oss-bin
+pkgver=8.4.2
+pkgrel=1
+pkgdesc='Data shippers for Elasticsearch'
+arch=('x86_64')
+url='https://www.elastic.co/products/beats'
+license=('Apache')
+depends=('glibc')
+conflicts=(auditbeat-oss)
+source=("https://artifacts.elastic.co/downloads/beats/auditbeat/auditbeat-${pkgver}-linux-x86_64.tar.gz"
+ "auditbeat-oss.service")
+sha512sums=('8e65c3f4de1a8d35dd988ca39b38cb17c157ab18461a8fb97d96adccb3663406b9405db7255b982e3a8b7bac3ebe9b6624864b6aa42cc491ea8c35807781d8e1'
+ '6c2b7ad706efbbaab55e2bd6a63dd85ee358aeed8255a829adeacdcd45d364520cc7f0328cfa966d61e911042d8fac40abc7ff36cdb7a834fc83df7da94fce13')
+backup=('etc/auditbeat-oss/auditbeat.yml', 'etc/auditbeat-oss/fields.yml')
+srcpath="auditbeat-${pkgver}-linux-x86_64"
+
+package() {
+ install -Dm755 "${srcdir}/${srcpath}/auditbeat" "${pkgdir}/usr/bin/auditbeat-oss"
+ install -Dm644 "${srcdir}/${srcpath}/auditbeat.yml" "${pkgdir}/etc/auditbeat-oss/auditbeat.yml"
+ install -Dm644 "${srcdir}/${srcpath}/auditbeat.reference.yml" "${pkgdir}/etc/auditbeat-oss/auditbeat.reference.yml"
+ install -Dm644 "${srcdir}/${srcpath}/fields.yml" "${pkgdir}/etc/auditbeat-oss/fields.yml"
+ install -Dm644 "auditbeat-oss.service" "${pkgdir}/usr/lib/systemd/system/auditbeat-oss.service"
+}
diff --git a/auditbeat-oss.service b/auditbeat-oss.service
new file mode 100644
index 000000000000..a72e9acdaa04
--- /dev/null
+++ b/auditbeat-oss.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Audit the activities of users and processes on your system to Elasticsearch OSS or OpenSearch.
+Documentation=https://www.elastic.co/guide/en/beats/auditbeat/7.12/index.html
+Wants=network-online.target
+After=network-online.target
+
+[Service]
+
+Environment="BEAT_LOG_OPTS=-e"
+Environment="BEAT_CONFIG_OPTS=-c /etc/auditbeat-oss/auditbeat.yml"
+Environment="BEAT_PATH_OPTS=-path.home /usr/share/auditbeat-oss -path.config /etc/auditbeat-oss -path.data /var/lib/auditbeat-oss -path.logs /var/log/auditbeat-oss"
+ExecStart=/usr/bin/auditbeat-oss $BEAT_LOG_OPTS $BEAT_CONFIG_OPTS $BEAT_PATH_OPTS
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target